为编程爱好者分享易语言教程源码的资源网
每日必买商品 易语言实地培训火热招生 建站,挂机,机器人服务器 A全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895
C全站文字广告,诚邀与您合作 乐易论坛 热门服务器秒杀 D全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895

网站首页 易语言相关 易语言模块源码 正文

易语言实现文件编码检测

三叶资源网 2019-02-11 易语言模块源码 859 ℃ 3 评论

易语言实现文件编码检测

.版本 2

.子程序 _临时子程序
.局部变量 ud, 整数型
.局部变量 root, 文本型
.局部变量 file, 文本型
.局部变量 data, 字节集

root = 取当前目录 () + “\test\”
枚举一下文件 (root)

.子程序 枚举一下文件
.参数 dir, 文本型
.局部变量 dirNew, 文本型
.局部变量 hFind, 整数型
.局部变量 findData, WIN32_FIND_DATAA
.局部变量 path, 文本型

dir = 子文本替换 (dir + “\”, “\\”, “\”, , , 真)
dirNew = dir
hFind = FindFirstFileA (dirNew + “*.*”, findData)
.如果真 (hFind ≠ #NULL)
    .循环判断首 ()
        .判断开始 (位与 (findData.dwFileAttributes, #FILE_ATTRIBUTE_DIRECTORY) ≠ 0)
            .判断开始 (findData.cFileName [1] = 46 且 findData.cFileName [2] = 0)  ' "."

            .判断 (findData.cFileName [1] = 46 且 findData.cFileName [2] = 46 且 findData.cFileName [3] = 0)  ' ".."

            .默认
                dirNew = dir + “\” + 到文本 (findData.cFileName)
                枚举一下文件 (dirNew)
            .判断结束


        .默认
            path = dir + 到文本 (findData.cFileName)
            输出调试文本 (“.” + 取文本右边 (path, 取文本长度 (path) - 取文本长度 (取运行目录 ())))
            输出调试文本 (到文本 ({ 9, 9 }) + 检测编码 (读入文件 (path)))
        .判断结束


    .循环判断尾 (FindNextFileA (hFind, findData))
.如果真结束


.子程序 检测编码, 文本型, , 新年快乐~  
.参数 data, 字节集
.局部变量 ud, 整数型
.局部变量 ret, 文本型

ud = uchardet_new ()
uchardet_handle_data (ud, data, 取字节集长度 (data))
uchardet_data_end (ud)
ret = uchardet_get_charset (ud)
uchardet_delete (ud)
返回 (ret)

@镇坛道德标杆

文件下载

Tags:文件编码检测易语言源码

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方⑤群:7366443

已有3位网友发表了看法:

  • 易语言教程站

    易语言教程站  评论于 [2019-07-21 12:46:37]  回复

    易语言实现文件编码检测-易语言模块源码

  • 易语言TV

    易语言TV  评论于 [2019-08-13 11:54:43]  回复

    易语言+文件编码检测

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网官方⑤群:三叶资源网官方⑤群

网站分类
随机tag
多线程培训RibbonUIRapidJSON易编辑框源码批量下载黑客E2EE互联网服务器套件AI文字转语音大众点评POST登陆财付通scriptcontrol对象易语言模块分析2144多线程注册例程源码按键精灵文字识别销毁时钟易语言5.8图片格式转换器动态调用DLL插件ExDUI视频教程
最新评论