为编程爱好者分享易语言教程源码的资源网
三叶资源网官方③群:33301895 网络创业点子 C全站文字广告,诚邀与您合作 三叶资源网培训教程视频 三叶资源网官方③群:33301895
三叶资源网官方③群:33301895 网络创业点子 B全站文字广告,诚邀与您合作 三叶资源网培训教程视频 三叶资源网官方③群:33301895

网站首页 易语言相关 易语言模块源码 正文

易语言实现文件编码检测

三叶资源网 2019-02-11 易语言模块源码 332 ℃ 0 评论

易语言实现文件编码检测

.版本 2

.子程序 _临时子程序
.局部变量 ud, 整数型
.局部变量 root, 文本型
.局部变量 file, 文本型
.局部变量 data, 字节集

root = 取当前目录 () + “\test\”
枚举一下文件 (root)

.子程序 枚举一下文件
.参数 dir, 文本型
.局部变量 dirNew, 文本型
.局部变量 hFind, 整数型
.局部变量 findData, WIN32_FIND_DATAA
.局部变量 path, 文本型

dir = 子文本替换 (dir + “\”, “\\”, “\”, , , 真)
dirNew = dir
hFind = FindFirstFileA (dirNew + “*.*”, findData)
.如果真 (hFind ≠ #NULL)
    .循环判断首 ()
        .判断开始 (位与 (findData.dwFileAttributes, #FILE_ATTRIBUTE_DIRECTORY) ≠ 0)
            .判断开始 (findData.cFileName [1] = 46 且 findData.cFileName [2] = 0)  ' "."

            .判断 (findData.cFileName [1] = 46 且 findData.cFileName [2] = 46 且 findData.cFileName [3] = 0)  ' ".."

            .默认
                dirNew = dir + “\” + 到文本 (findData.cFileName)
                枚举一下文件 (dirNew)
            .判断结束


        .默认
            path = dir + 到文本 (findData.cFileName)
            输出调试文本 (“.” + 取文本右边 (path, 取文本长度 (path) - 取文本长度 (取运行目录 ())))
            输出调试文本 (到文本 ({ 9, 9 }) + 检测编码 (读入文件 (path)))
        .判断结束


    .循环判断尾 (FindNextFileA (hFind, findData))
.如果真结束


.子程序 检测编码, 文本型, , 新年快乐~  
.参数 data, 字节集
.局部变量 ud, 整数型
.局部变量 ret, 文本型

ud = uchardet_new ()
uchardet_handle_data (ud, data, 取字节集长度 (data))
uchardet_data_end (ud)
ret = uchardet_get_charset (ud)
uchardet_delete (ud)
返回 (ret)

@镇坛道德标杆

文件下载

Tags:文件编码检测易语言源码

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方③群:33301895

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网官方③群:三叶资源网官方③群

网站分类
随机tag
Vmprotect电商解析HTML语句读卡器开发脚本源码移动咪咕单纯挖矿钓鱼Bass音频库QQ群成员提取Aplayer百度API套接字E2EE异或校验屏幕锁屏工具觅风易语言教程数组剖析Edge浏览器云的多窗口界面支持库
最新评论