为编程爱好者分享易语言教程源码的资源网
免费易语言注册机教程 程序员交流社区 挂机,挂机器人服务器95一年 广告位招租 三叶资源网交流群④ 【采购季】上云仅¥223/3年
免费易语言注册机教程 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年
程序员交流社区 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年

网站首页 易语言相关 易语言例程 正文

酷Q插件 百度识图源码

三叶资源网 2019-03-14 易语言例程 875 ℃ 6 评论

酷Q插件 百度识图源码

.版本 2
.支持库 spec

.如果 (取文本左边 (msg, 取文本长度 (“识链接”)) = “识链接”)  ' 取文本左边
    msg = 子文本替换 (msg, “识链接”, , , 1, 真)  ' 取文本左边
    返回文本 = 编码_utf8到gb2312 (到文本 (网页_访问 (“http://image.baidu.com/n/pc_search?queryImageUrl=” + msg + “&querySign=&simid=&fm=home&pos=&uptype=paste”)))
    正则.创建 (“<a class=” + #引号 + “source-card-topic-title-link” + #引号 + “ href=” + #引号 + “(.*?)” + #引号 + “ data-word-index=” + #引号 + “\d+” + #引号 + “ target=” + #引号 + “_blank” + #引号 + “ >(.*?)</a>”, 返回文本)
    .计次循环首 (正则.取匹配数量 (), n)
        a = a + 正则.取子匹配文本 (n, 1) + #换行符 + 正则.取子匹配文本 (n, 2) + #换行符
    .计次循环尾 ()
    调试输出 (a)
    CQ.发送群消息 (fromGroup, a)
    .如果 (a = “”)
        CQ.发送群消息 (fromGroup, “没有找到与图片相关的内容。”)
    .否则

    .如果结束
    返回 (#消息_忽略)
.否则

.如果结束

.如果 (取文本左边 (msg, 取文本长度 (“识图”)) = “识图”)  ' 取文本左边
    msg = 子文本替换 (msg, “识图”, , , 1, 真)  ' 取文本左边
    uir = 读配置项 (取运行目录 () + “\data\image\” + 文本_取出中间文本 (msg, “[CQ:image,file=”, “]”) + “.cqimg”, “image”, “url”, )

    返回文本 = 编码_utf8到gb2312 (到文本 (网页_访问 (“http://image.baidu.com/n/pc_search?queryImageUrl=” + uir + “&querySign=&simid=&fm=home&pos=upload&uptype=upload_pc”)))
    正则.创建 (“<a class=” + #引号 + “source-card-topic-title-link” + #引号 + “ href=” + #引号 + “(.*?)” + #引号 + “ data-word-index=” + #引号 + “\d+” + #引号 + “ target=” + #引号 + “_blank” + #引号 + “ >(.*?)</a>”, 返回文本)
    .计次循环首 (正则.取匹配数量 (), n)
        a = a + 正则.取子匹配文本 (n, 1) + #换行符 + 正则.取子匹配文本 (n, 2) + #换行符
    .计次循环尾 ()
    调试输出 (a)
    CQ.发送群消息 (fromGroup, a)
    .如果 (a = “”)
        CQ.发送群消息 (fromGroup, “没有找到与图片相关的内容。”)
    .否则

    .如果结束

.否则

.如果结束
返回 (#消息_忽略)
文件下载

Tags:酷Q插件百度识图源码

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

已有6位网友发表了看法:

  • 易飞扬

    易飞扬  评论于 [2019-04-29 12:37:40]  回复

    酷q+百度ai插件

  • 访客

    访客  评论于 [2019-09-10 20:05:50]  回复

    什么变量都不写==用处不大

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
Asm按键精灵基础练习界面控件配置保存微信加人抖音检测代理IPfiddlercoreapi汇编版ByteBuffer引流WKE卡盟管理系统数学函数图像内存操作自动回复折线图源码创建快捷方式Fiddler拦截模式webqq翻译助手
最新评论
友情链接