为编程爱好者分享易语言教程源码的资源网
易语言网站app定制QQ1918812225 网络赚钱,从这里开始 想日赚300到3000来 三叶资源网培训教程视频 三叶资源网官方③群:33301895
三叶资源网官方③群:33301895 网络赚钱,从这里开始 B全站文字广告,诚邀与您合作 三叶资源网培训教程视频 三叶资源网官方③群:33301895

网站首页 易语言相关 易语言例程 正文

酷Q插件 百度识图源码

三叶资源网 2019-03-14 易语言例程 155 ℃ 1 评论

酷Q插件 百度识图源码

.版本 2
.支持库 spec

.如果 (取文本左边 (msg, 取文本长度 (“识链接”)) = “识链接”)  ' 取文本左边
    msg = 子文本替换 (msg, “识链接”, , , 1, 真)  ' 取文本左边
    返回文本 = 编码_utf8到gb2312 (到文本 (网页_访问 (“http://image.baidu.com/n/pc_search?queryImageUrl=” + msg + “&querySign=&simid=&fm=home&pos=&uptype=paste”)))
    正则.创建 (“<a class=” + #引号 + “source-card-topic-title-link” + #引号 + “ href=” + #引号 + “(.*?)” + #引号 + “ data-word-index=” + #引号 + “\d+” + #引号 + “ target=” + #引号 + “_blank” + #引号 + “ >(.*?)</a>”, 返回文本)
    .计次循环首 (正则.取匹配数量 (), n)
        a = a + 正则.取子匹配文本 (n, 1) + #换行符 + 正则.取子匹配文本 (n, 2) + #换行符
    .计次循环尾 ()
    调试输出 (a)
    CQ.发送群消息 (fromGroup, a)
    .如果 (a = “”)
        CQ.发送群消息 (fromGroup, “没有找到与图片相关的内容。”)
    .否则

    .如果结束
    返回 (#消息_忽略)
.否则

.如果结束

.如果 (取文本左边 (msg, 取文本长度 (“识图”)) = “识图”)  ' 取文本左边
    msg = 子文本替换 (msg, “识图”, , , 1, 真)  ' 取文本左边
    uir = 读配置项 (取运行目录 () + “\data\image\” + 文本_取出中间文本 (msg, “[CQ:image,file=”, “]”) + “.cqimg”, “image”, “url”, )

    返回文本 = 编码_utf8到gb2312 (到文本 (网页_访问 (“http://image.baidu.com/n/pc_search?queryImageUrl=” + uir + “&querySign=&simid=&fm=home&pos=upload&uptype=upload_pc”)))
    正则.创建 (“<a class=” + #引号 + “source-card-topic-title-link” + #引号 + “ href=” + #引号 + “(.*?)” + #引号 + “ data-word-index=” + #引号 + “\d+” + #引号 + “ target=” + #引号 + “_blank” + #引号 + “ >(.*?)</a>”, 返回文本)
    .计次循环首 (正则.取匹配数量 (), n)
        a = a + 正则.取子匹配文本 (n, 1) + #换行符 + 正则.取子匹配文本 (n, 2) + #换行符
    .计次循环尾 ()
    调试输出 (a)
    CQ.发送群消息 (fromGroup, a)
    .如果 (a = “”)
        CQ.发送群消息 (fromGroup, “没有找到与图片相关的内容。”)
    .否则

    .如果结束

.否则

.如果结束
返回 (#消息_忽略)
文件下载

Tags:酷Q插件百度识图源码

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方③群:33301895

已有1位网友发表了看法:

  • 易飞扬

    易飞扬  评论于 [2019-04-29 12:37:40]  回复

    酷q+百度ai插件

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网官方③群:三叶资源网官方③群

网站分类
随机tag
RAR注释POST上传自动回复开心ol前台打怪Windows Shelloffice2019激活取QQ昵称社会网络domCharles采集源码弹幕解析加QQ好友微信支付多线程注册系统工具源码魔鬼作坊微信HookExDUI视频教程图像处理模块
最新评论