为编程爱好者分享易语言教程源码的资源网
易语言源码视频(易学院) A全站文字广告,诚邀与您合作 建站,挂机器人,挂监控服务器 A全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895
每日必买商品 20块一小时,一小时一结账 299买3年腾讯云服务器 B全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895

网站首页 易语言相关 易语言例程 正文

易语言正则整理排序多列文本源码

三叶资源网 2019-06-12 易语言例程 34 ℃ 0 评论

易语言正则排序多列文本源码

@cf2006a

.版本 2
.支持库 RegEx
.支持库 EDataStructure

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 a, 文本型
.局部变量 正则_取数据, 正则表达式
.局部变量 正则_获取到, 搜索结果, , "0"
.局部变量 去重复, 节点
.局部变量 价格, 小数型, , "0"
.局部变量 表达式, 文本型
.局部变量 日期, 文本型
.局部变量 i, 整数型
.局部变量 l, 整数型

日期 = “20180102”
a = 编辑框1.内容
正则_取数据.创建 (“\b(\d+\.\d+)\b”, )
正则_获取到 = 正则_取数据.搜索全部 (a)
.计次循环首 (取数组成员数 (正则_获取到), i)
    .如果真 (去重复.加入属性 (正则_获取到 [i].取子匹配文本 (a, 1, ), 真))
        加入成员 (价格, 到数值 (正则_获取到 [i].取子匹配文本 (a, 1, )))
    .如果真结束

.计次循环尾 ()
数组排序 (价格, )
' 0112   09:32:18   4.15   +913
表达式 = “(\d{4}   \d{2}:\d{2}:\d{2}   价格   [+|-]\d+)”
.计次循环首 (取数组成员数 (价格), i)
    正则_取数据.创建 (子文本替换 (表达式, “价格”, 到文本 (价格 [i]), , , 真), )
    正则_获取到 = 正则_取数据.搜索全部 (a)
    .计次循环首 (取数组成员数 (正则_获取到), l)
        编辑框2.加入文本 (正则_获取到 [l].取子匹配文本 (a, 1, ) + #换行符)

    .计次循环尾 ()
.计次循环尾 ()
文件下载

Tags:正则整理排序

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方③群:33301895

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网官方③群:三叶资源网官方③群

网站分类
随机tag
百度网盘多线程特训班拼多多下单JMAIL.dll引流软件源码群控模拟器彗星小助手工具箱聊呗火山安卓TCP通信吃鸡泰服矩阵Sqlite本地库自动循环显示列表项目界面UI源码无限长度按键精灵基础练习哈罗单车ERP管理系统CURL知乎
最新评论