为编程爱好者分享易语言教程源码的资源网
每日必买商品 易语言实地培训火热招生 建站,挂机,机器人服务器 A全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895
每日优惠商品抢购 乐易论坛 热门服务器一年99元 D全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895

网站首页 易语言相关 易语言模块源码 正文

易语言窗口繁体化模块源码

三叶资源网 2019-06-12 易语言模块源码 232 ℃ 0 评论

易语言窗口繁体化模块源码

@k-bird

.版本 2
.支持库 iext
.支持库 eGrid
.支持库 cncnv

.子程序 窗口繁体化, , 公开
.参数 窗口, 窗口
.局部变量 Found_ID, 整数型
.局部变量 焦点标签, 透明标签
.局部变量 焦点工具条, 工具条
.局部变量 焦点按钮, 按钮
.局部变量 焦点分组框, 分组框, , , ' 本源码来自三叶资源网(www.sanye.cx)
.局部变量 焦点选择夹, 选择夹
.局部变量 焦点高级表格, 高级表格
.局部变量 焦点单选框, 单选框
.局部变量 焦点选择框, 选择框
.局部变量 焦点树型框, 树型框
.局部变量 焦点普通标签, 标签
.局部变量 焦点状态条, 状态条
.局部变量 焦点通用对话框, 通用对话框
.局部变量 焦点组合框, 组合框
.局部变量 i, 整数型
.局部变量 k, 整数型
.局部变量 Z, 整数型

.如果真 (GetUserDefaultLCID () = 1028)  ' 繁体中文 1028 简体中文 2052 英文 1033
    Found_ID = 寻找组件 (窗口, , “透明标签”, , )
    .计次循环首 (取找到组件数目 (Found_ID), i)
        焦点标签 = 取所找到组件 (Found_ID, i - 1)
        焦点标签.标题 = 内码转换 (焦点标签.标题, #GBK到BIG5)
    .计次循环尾 ()
    清除组件寻找句柄 (Found_ID)
    ' ************************************标签***********************************
    Found_ID = 寻找组件 (窗口, , “标签”, , )
    .计次循环首 (取找到组件数目 (Found_ID), i)
        焦点普通标签 = 取所找到组件 (Found_ID, i - 1)
        焦点普通标签.标题 = 内码转换 (焦点普通标签.标题, #GBK到BIG5)
    .计次循环尾 ()
    清除组件寻找句柄 (Found_ID)
    ' ************************************工具条***********************************
    Found_ID = 寻找组件 (窗口, , “工具条”, , )
    .计次循环首 (取找到组件数目 (Found_ID), i)
        焦点工具条 = 取所找到组件 (Found_ID, i - 1)
        .计次循环首 (焦点工具条.取按钮数 (), k)
            焦点工具条.置标题 (k - 1, 内码转换 (焦点工具条.取标题 (k - 1), #GBK到BIG5))
            焦点工具条.置提示文本 (k - 1, 内码转换 (焦点工具条.取提示文本 (k - 1), #GBK到BIG5))
        .计次循环尾 ()
    .计次循环尾 ()' 本源码来自三叶资源网(www.sanye.cx)
    清除组件寻找句柄 (Found_ID)
    ' ************************************按钮***********************************
    Found_ID = 寻找组件 (窗口, , “按钮”, , )
    .计次循环首 (取找到组件数目 (Found_ID), i)
        焦点按钮 = 取所找到组件 (Found_ID, i - 1)
        焦点按钮.标题 = 内码转换 (焦点按钮.标题, #GBK到BIG5)
    .计次循环尾 ()
    清除组件寻找句柄 (Found_ID)
    ' ************************************分组框***********************************
    Found_ID = 寻找组件 (窗口, , “分组框”, , )
    .计次循环首 (取找到组件数目 (Found_ID), i)
        焦点分组框 = 取所找到组件 (Found_ID, i - 1)
        焦点分组框.标题 = 内码转换 (焦点分组框.标题, #GBK到BIG5)
    .计次循环尾 ()
    清除组件寻找句柄 (Found_ID)
    ' ************************************工具条***********************************
    Found_ID = 寻找组件 (窗口, , “高级表格”, , )
    .计次循环首 (取找到组件数目 (Found_ID), i)
        焦点高级表格 = 取所找到组件 (Found_ID, i - 1)
        .计次循环首 (焦点高级表格.行数, k)
            .计次循环首 (焦点高级表格.列数, Z)
                焦点高级表格.置数据 (k - 1, Z - 1, #表格常量.文本型, 内码转换 (焦点高级表格.取数据 (k - 1, Z - 1), #GBK到BIG5))
            .计次循环尾 ()
            处理事件 ()
        .计次循环尾 ()
    .计次循环尾 ()
    清除组件寻找句柄 (Found_ID)
    ' ************************************单选框***********************************
    Found_ID = 寻找组件 (窗口, , “单选框”, , )
    .计次循环首 (取找到组件数目 (Found_ID), i)
        焦点单选框 = 取所找到组件 (Found_ID, i - 1)
        焦点单选框.标题 = 内码转换 (焦点单选框.标题, #GBK到BIG5)
    .计次循环尾 ()
    清除组件寻找句柄 (Found_ID)
    ' ************************************选择框***********************************
    Found_ID = 寻找组件 (窗口, , “选择框”, , )
    .计次循环首 (取找到组件数目 (Found_ID), i)
        焦点选择框 = 取所找到组件 (Found_ID, i - 1)
        焦点选择框.标题 = 内码转换 (焦点选择框.标题, #GBK到BIG5)
    .计次循环尾 ()
    清除组件寻找句柄 (Found_ID)
    ' ************************************树型框***********************************
    Found_ID = 寻找组件 (窗口, , “树型框”, , )
    .计次循环首 (取找到组件数目 (Found_ID), i)
        焦点树型框 = 取所找到组件 (Found_ID, i - 1)
        .计次循环首 (焦点树型框.取项目数 (), k)
            焦点树型框.置项目文本 (k - 1, 内码转换 (焦点树型框.取项目文本 (k - 1), #GBK到BIG5))
        .计次循环尾 ()
    .计次循环尾 ()
    清除组件寻找句柄 (Found_ID)
    ' ************************************状态条***********************************
    Found_ID = 寻找组件 (窗口, , “状态条”, , )
    .计次循环首 (取找到组件数目 (Found_ID), i)
        焦点状态条 = 取所找到组件 (Found_ID, i - 1)
        .计次循环首 (焦点状态条.取栏目数 (), k)
            焦点状态条.置文本 (k - 1, 内码转换 (焦点状态条.取文本 (k - 1), #GBK到BIG5))
        .计次循环尾 ()
    .计次循环尾 ()
    清除组件寻找句柄 (Found_ID)
    ' ************************************通用对话框***********************************
    Found_ID = 寻找组件 (窗口, , “通用对话框”, , )
    .计次循环首 (取找到组件数目 (Found_ID), i)
        焦点通用对话框 = 取所找到组件 (Found_ID, i - 1)
        焦点通用对话框.过滤器 = 内码转换 (焦点通用对话框.过滤器, #GBK到BIG5)
        焦点通用对话框.标题 = 内码转换 (焦点通用对话框.标题, #GBK到BIG5)
    .计次循环尾 ()
    清除组件寻找句柄 (Found_ID)
    ' ************************************组合框***********************************
    Found_ID = 寻找组件 (窗口, , “组合框”, , )
    .计次循环首 (取找到组件数目 (Found_ID), i)
        焦点组合框 = 取所找到组件 (Found_ID, i - 1)
        .计次循环首 (焦点组合框.取项目数 (), k)
            焦点组合框.置项目文本 (k - 1, 内码转换 (焦点组合框.取项目文本 (k - 1), #GBK到BIG5))
        .计次循环尾 ()
    .计次循环尾 ()
    清除组件寻找句柄 (Found_ID)

.如果真结束
文件下载

Tags:窗口繁体化

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方⑤群:7366443

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网官方⑤群:三叶资源网官方⑤群

网站分类
随机tag
微信hook人工智能桌面透明背景时钟ICMP引流软件源码自动同意进群获取窗口内鼠标坐标高仿WPF界面压枪辅助易语言源码Safengine手动记牌炫彩设计器工程树型框项目STEAM区块链技术卡盟管理系统http访问左右按键编码转换
最新评论