为编程爱好者分享易语言教程源码的资源网
香港欧美socks5|https长效API 每日必买商品 建站,挂机,机器人服务器 A全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895
D全站文字广告,诚邀与您合作 每日优惠商品抢购 热门服务器一年99元 C全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895

网站首页 易语言相关 网络相关源码 正文

Galanz批量注册登录源码

三叶资源网 2019-06-18 网络相关源码 282 ℃ 1 评论

Galanz批量注册登录源码

@2335152321

.版本 2
.支持库 iext
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 人, 整数型
.程序集变量 次, 整数型
.程序集变量 B, 整数型
.程序集变量 t, 整数型

.子程序 __启动窗口_创建完毕

编辑框3.内容 = “60”
编辑框4.内容 = “120”

.子程序 _按钮1_被单击

key = 编辑框2.内容
透明标签12.标题 = “正在尝试注册登录”
线程_启动 (&开始)

.子程序 开始

.如果真 (到整数 (人数.内容) = 0 且 到整数 (次数.内容) = 0)
    获取手机号 ()
    返回 ()
.如果真结束
.如果真 (到整数 (人数.内容) ≠ 0 且 到整数 (次数.内容) = 0)
    .判断开始 (人 = 到整数 (人数.内容))
        信息框 (“操作完成,执行次数:” + 到文本 (次), 0, , )
    .默认
        获取手机号 ()
    .判断结束

.如果真结束
.如果真 (到整数 (人数.内容) = 0 且 到整数 (次数.内容) ≠ 0)
    .判断开始 (次 = 到整数 (次数.内容))
        信息框 (“操作完成,执行次数:” + 到文本 (次), 0, , )
    .默认
        获取手机号 ()
    .判断结束

.如果真结束


.子程序 获取手机号
.局部变量 待解析, 文本型

次 = 次 + 1
透明标签8.标题 = 到文本 (次) + “次”
待解析 = 到文本 (网页_访问_对象 (“http://47.97.118.96:9180/service.asmx/GetHM2Str?token=” + key + “&xmid=173946&sl=1&lx=0&a1=&a2=&pk=&ks=0&rj=0 ”))
调试输出 (待解析)
号码 = 文本_取右边 (待解析, “hm=”)
.判断开始 (号码 = “”)
    .如果真 (待解析 = “-8”)
        释放号码 ()
    .如果真结束
    返回 ()
.默认
    引索 = 超级列表框1.插入表项 (-1, 号码, , , , )
    .判断开始 (登录 (号码))
        获取验证码 ()
    .默认
        超级列表框1.置标题 (引索, 2, “该用户已存在”)
        释放号码 ()
        获取手机号 ()
    .判断结束

.判断结束


.子程序 释放号码

网页_访问_对象 (“http://47.96.183.58:9180/service.asmx/sfHmStr?token=” + key + “&hm=” + 号码)

.子程序 获取验证码

网页_访问_对象 (“https://api.galanz.com/prod/app/sms/sendMsg”, 1, “mobile=” + 号码 + “&msgType=sms_moblie_register”)
获取短信 ()

.子程序 获取短信
.局部变量 待解析, 文本型
.局部变量 i, 整数型

待解析 = 到文本 (网页_访问_对象 (“http://47.97.118.96:9180/service.asmx/GetYzm2Str?token=” + key + “&hm=” + 号码 + “&xmid=173946&sf=1”))
.判断循环首 (待解析 = “1”)
    待解析 = 编码_Utf8到Ansi (网页_访问_对象 (“http://47.97.118.96:9180/service.asmx/GetYzm2Str?token=” + key + “&hm=” + 号码 + “&xmid=173946&sf=1”))
    超级列表框1.置标题 (引索, 1, “第” + 到文本 (i) + “次获取验证码”)
    验证码 = 文本_取出中间文本 (待解析, “验证码”, “,”)
    i = i + 1
    延迟 (1000)
    .如果真 (验证码 = “-1”)
        获取手机号 ()
        返回 ()
    .如果真结束
    .如果真 (i = 15)
        超级列表框1.置标题 (引索, 1, “获取超时”)
        获取手机号 ()
        返回 ()
    .如果真结束
    调试输出 (待解析)
.判断循环尾 ()
超级列表框1.置标题 (引索, 1, 验证码)
注册 ()

.子程序 注册, 逻辑型
.局部变量 post, 文本型
.局部变量 待解析, 文本型

post = “mobile=” + 号码 + “&password=a12345&code=” + 验证码 + “&invitationCode=” + 编辑框1.内容
待解析 = 编码_Utf8到Ansi (网页_访问_对象 (“https://api.galanz.com/prod/app/appRegister”, 1, post))
调试输出 (待解析)
.如果真 (寻找文本 (待解析, “该用户已存在”, , 假) ≠ -1)
    超级列表框1.置标题 (引索, 2, “该用户已存在”)
    获取手机号 ()
    返回 (假)
.如果真结束
.如果真 (寻找文本 (待解析, “操作成功”, , 假) ≠ -1)
    超级列表框1.置标题 (引索, 2, “注册成功”)
    登录 (号码)
    返回 (真)
.如果真结束
.如果真 (验证码 = “”)
    超级列表框1.置标题 (引索, 2, “验证码错误”)
    获取手机号 ()
    返回 (假)
.如果真结束

.判断开始 (t > 10)
    超级列表框1.置标题 (引索, 2, “注册失败”)
    t = 0
    B = B + 1
    透明标签2.标题 = “注册失败:” + 到文本 (B) + “次”
    获取手机号 ()
.默认
    t = t + 1
    超级列表框1.置标题 (引索, 2, “第:” + 到文本 (t) + “次注册”)
    延迟 (1000)
    注册 ()
.判断结束
返回 (假)

.子程序 登录, 逻辑型
.参数 手机号, 文本型
.局部变量 待解析, 文本型
.局部变量 post, 文本型
.局部变量 结果, 逻辑型
.局部变量 i, 整数型

post = “password=a12345&username=” + 手机号
待解析 = 编码_Utf8到Ansi (网页_访问_对象 (“https://api.galanz.com/prod/app/app_login”, 1, post))
.判断开始 (寻找文本 (待解析, “用户名不存在”, , 假) ≠ -1)
    结果 = 真
.默认
    结果 = 假
    .如果真 (寻找文本 (待解析, “处理成功”, , 假) ≠ -1)
        超级列表框1.置标题 (引索, 3, “登录成功”)
        人 = 人 + 1
        透明标签9.标题 = 到文本 (人) + “人”
        置随机数种子 ()
        i = 取随机数 (到整数 (编辑框3.内容), 到整数 (编辑框4.内容))
        .判断循环首 (i ≠ 0)
            透明标签12.标题 = “休息” + 到文本 (i) + “秒后继续”
            i = i - 1
            延迟 (1000)
        .判断循环尾 ()
        透明标签12.标题 = “正在尝试注册”
        开始 ()
    .如果真结束

.判断结束
调试输出 (待解析)
返回 (结果)
文件下载

Tags:Galanz批量注册

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

已有1位网友发表了看法:

  • 易语言TV

    易语言TV  评论于 [2019-10-01 14:59:41]  回复

    iapp分享次数进入源码

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
分段加密支持库教程svg图片转换酷Q机器人QQ群发插件源码正则抖音脚本cookie蚁群算法QQ二维码登录仿百度网盘快速启动变体型源码.通信开源识别算法车牌识别窗口阴影Galanz批量注册JS加密
最新评论