为编程爱好者分享易语言教程源码的资源网
每日必买商品 易语言实地培训火热招生 建站,挂机,机器人服务器 A全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895
易语言大漠脚本交流群 乐易论坛 热门服务器秒杀 D全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895

网站首页 易语言相关 易语言例程 正文

树形框项目切换易语言源码

三叶资源网 2019-06-19 易语言例程 61 ℃ 0 评论
.版本 2
.支持库 iext

.程序集 窗口程序集_启动窗口
.程序集变量 项目_缩进层次2, 整数型
.程序集变量 项目_缩进层次2_文本, 文本型
.程序集变量 项目_缩进层次3, 整数型
.程序集变量 项目_缩进层次3_文本, 文本型

.子程序 __启动窗口_创建完毕
.局部变量 项目, 整数型
.局部变量 i, 整数型

项目 = 树型框1.加入项目 (, “演示项目”, , , , , )
.计次循环首 (20, i)
    树型框1.加入项目 (项目, “演示项目” + 到文本 (i), , , , , )
.计次循环尾 ()
树型框1.扩展 (项目)

.子程序 _树型框1_双击项目

_双击项目 (树型框1.取缩进层次 (树型框1.现行选中项), 树型框1.现行选中项)

.子程序 _双击项目
.参数 缩进层次, 整数型
.参数 项目, 整数型
.局部变量 项目文本, 文本型
.局部变量 i, 整数型

项目文本 = 树型框1.取项目文本 (项目)
.判断开始 (缩进层次 = 2)
    .如果 (项目_缩进层次2 > 0)
        .判断循环首 (树型框1.是否有子项目 (项目_缩进层次2))
            树型框1.删除项目 (项目_缩进层次2 + 1)
        .判断循环尾 ()
        .计次循环首 (树型框1.取项目数 (), i)
            .如果真 (文本比较 (项目文本, 树型框1.取项目文本 (i), 真) = 0)
                项目_缩进层次2 = i
                项目_缩进层次2_文本 = 项目文本
            .如果真结束

        .计次循环尾 ()
    .否则
        项目_缩进层次2 = 项目
        项目_缩进层次2_文本 = 项目文本
    .如果结束
    展开项目_缩进层次2 (项目_缩进层次2)
.判断 (缩进层次 = 3)
    .如果 (项目_缩进层次3 > 0)
        .判断循环首 (树型框1.是否有子项目 (项目_缩进层次3))
            树型框1.删除项目 (项目_缩进层次3 + 1)
        .判断循环尾 ()
        .计次循环首 (树型框1.取项目数 (), i)
            .如果真 (文本比较 (项目文本, 树型框1.取项目文本 (i), 真) = 0)
                项目_缩进层次3 = i
                项目_缩进层次3_文本 = 项目文本
            .如果真结束

        .计次循环尾 ()
    .否则
        项目_缩进层次3 = 项目
        项目_缩进层次3_文本 = 项目文本
    .如果结束
    展开项目_缩进层次3 (项目_缩进层次3)
.默认

.判断结束


.子程序 展开项目_缩进层次2
.参数 项目, 整数型
.局部变量 i, 整数型

.计次循环首 (10, i)
    树型框1.加入项目 (项目, 项目_缩进层次2_文本 + “_” + 到文本 (i), , , , , )
.计次循环尾 ()
树型框1.扩展 (项目)

.子程序 展开项目_缩进层次3
.参数 项目, 整数型
.局部变量 i, 整数型

.计次循环首 (10, i)
    树型框1.加入项目 (项目, 项目_缩进层次3_文本 + “_” + 到文本 (i), , , , , )
.计次循环尾 ()
树型框1.扩展 (项目)

.子程序 _树型框1_即将收缩, 逻辑型
.参数 项目索引, 整数型

返回 (假)

@wcf147

文件下载

Tags:树形框项目切换易语言源码

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方③群:33301895

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网官方③群:三叶资源网官方③群

网站分类
随机tag
图形按钮编码一条游走的龙QQ采集窗口位置控制模块黑客易语言多开中控源码魔鬼作坊准星拖动Unicode源码.酷Q插件SendMessage易语言客户端趣头条支付宝DXTC图片算法资源管理器QQ注册代理采集
最新评论