为编程爱好者分享易语言教程源码的资源网
香港欧美socks5|https长效API 每日必买商品 建站,挂机,机器人服务器 A全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895
D全站文字广告,诚邀与您合作 每日优惠商品抢购 热门服务器一年99元 C全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895

网站首页 易语言相关 易语言例程 正文

易语言用易包做插件

三叶资源网 2019-06-20 易语言例程 177 ℃ 0 评论

易语言用易包做插件

@qq1101672929

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 易包名称数组, 文本型, , "0"

.子程序 __启动窗口_创建完毕
.局部变量 文件数组, 文本型, , "0"
.局部变量 i, 整数型

.计次循环首 (枚举易包 (文件数组), i)
    加入成员 (易包名称数组, 取文件名 (文件数组 [i]))
    .如果 (载入易包数据 (易包名称数组 [i], 读入文件 (文件数组 [i])))
        调试输出 (“易包:[” + 易包名称数组 [i] + “]加载成功!”)
    .否则
        调试输出 (“易包:[” + 易包名称数组 [i] + “]加载失败!”)
    .如果结束

.计次循环尾 ()

.子程序 GetEpkAddress, 整数型
.参数 易包名称, 文本型
.参数 函数名称, 文本型
.局部变量 ecx, 整数型
.局部变量 addresszs, 整数型
.局部变量 i, 整数型
.局部变量 n, 整数型
.局部变量 name, 文本型
.局部变量 epkname, 文本型
.局部变量 函数名, 文本型

.如果真 (易包名称 = “” 或 函数名称 = “”)
    返回 (0)
.如果真结束
易包名称 = 到大写 (易包名称)
i = 取模块句柄_ (“krnln.fne”)
.如果真 (i = 0)
    i = 取模块句柄_ (“krnln.fnr”)
.如果真结束
ecx = 取进程地址_ (i, “IsEPKLoaded”)
ecx = 指针到整数 (ecx + 8)
' 本源码来自易语言资源网(www.5A5X.com)
ecx = ecx + 516
addresszs = 指针到整数 (ecx + 12)
ecx = 指针到整数 (ecx + 20)
ecx = ecx + 4
.计次循环首 (addresszs, i)
    n = 指针到整数 (ecx + 8)
    name = 指针到文本 (n)
    GetEpkName (name, epkname, 函数名)
    .如果真 (易包名称 = epkname 且 函数名称 = 函数名)
        调试输出 (epkname)
        返回 (指针到整数 (ecx + 12))
    .如果真结束
    ecx = ecx + 16
.计次循环尾 ()
返回 (0)

.子程序 GetEpkName
.参数 text, 文本型
.参数 epkname, 文本型, 参考
.参数 函数名, 文本型, 参考
.局部变量 n, 整数型
.局部变量 h, 整数型

n = 寻找文本 (text, “.”, , 假)
.如果真 (n ≠ -1)
    epkname = 取文本左边 (text, n - 1)
    h = 寻找文本 (text, “@”, , 假)
    n = n + 1
    函数名 = 取文本中间 (text, n, h - n)
.如果真结束
' 本源码来自易语言资源网(www.5A5X.com)

.子程序 _按钮1_被单击
.局部变量 i, 整数型
.局部变量 地址, 整数型

.计次循环首 (取数组成员数 (易包名称数组), i)
    地址 = GetEpkAddress (易包名称数组 [i], “子程序1”)
    .如果 (地址 ≠ 0)
        Call (地址, i, 易包名称数组 [i], “窗口标题”, _启动窗口, 标签1)
    .否则
        调试输出 (“易包:” + 易包名称数组 [i] + “ 调用失败”)
    .如果结束
    、
.计次循环尾 ()
调试输出 (“执行完成~~”)


.子程序 Call, 整数型, , by:易语言我吃了
.参数 子程序地址
.参数 参数1, , 可空
.参数 参数2, 文本型, 参考 可空
.参数 提示标题, 文本型, 参考 可空
.参数 参数3, 窗口, 参考 可空
.参数 参数4, 标签, 参考 可空
.参数 参数5, , 可空
.参数 参数6, , 可空
.参数 参数7, , 可空
.参数 参数8, , 可空
.参数 参数9, , 可空
.参数 参数10, , 可空
.参数 参数11, , 可空
.参数 参数12, , 可空
.参数 参数13, , 可空
.参数 参数14, , 可空

置入代码 ({ 86, 190, 15, 0, 0, 0, 141, 77, 8, 141, 76, 241, 252, 139, 65, 4, 133, 192, 116, 2, 255, 49, 78, 131, 233, 8, 133, 246, 117, 239, 255, 85, 8, 94, 201, 194, 124, 0 })
返回 (0)
文件下载

Tags:易语言易包做插件

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
iiilab视频解析吃鸡辅助易语言资源网视频教程获取正文算法sign算法界面设计黑月插件服务器组件PC微信猴子分桃线程安全蓝奏网盘mysql黑月界面类3.8字节集搜索酷Q源代码魔鬼作坊微信加人屏幕保护撞球
最新评论