为编程爱好者分享易语言教程源码的资源网
香港欧美socks5|https长效API 每日必买商品 建站,挂机,机器人服务器 A全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895
D全站文字广告,诚邀与您合作 每日优惠商品抢购 热门服务器一年99元 C全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895

网站首页 易语言相关 易语言例程 正文

易语言 利用超级列表框多线程参数传递文本

三叶资源网 2019-07-11 易语言例程 202 ℃ 3 评论
.版本 2
.支持库 iext
.支持库 EThread
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 i, 整数型

.计次循环首 (超级列表框1.取表项数 (), i)
    启动线程 (&子程序1, i, )
    延迟 (20)
.计次循环尾 ()

.子程序 __启动窗口_创建完毕
.局部变量 i, 整数型

' 把所有文本内容导入到超级列表框
.计次循环首 (100, i)
    超级列表框1.插入表项 (-1, “草泥马” + 到文本 (i), , , , )
.计次循环尾 ()

.子程序 子程序1
.参数 线程传递过来的数字, 整数型

' 因为超级列表框是从0开始的所以要-1
调试输出 (超级列表框1.取标题 (线程传递过来的数字 - 1, 0))

@书写寂伤

文件下载

Tags:

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

已有3位网友发表了看法:

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
设置系统原子锁易语言版本QQ邮箱彩票开奖遗漏组合分析考勤机对比两块内存问道辅助内存脚本知乎递归XUI限制窗口位置和尺寸防撤回sqlite3wordpress跳一跳大众点评目录枚举易语言游戏开发MTP发信
最新评论