为编程爱好者分享易语言教程源码的资源网
桌面必备手办!!! 每日必买商品 挂机,挂机器人服务器99一年 便宜好看的文具盒 三叶资源网交流群④ 点我看看呗!!
桌面必备手办!!! 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 点我看看呗!!
桌面必备手办!!! 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 点我看看呗!!

网站首页 易语言相关 易语言例程 正文

易语言获取指定进程IP源码

三叶资源网 2019-09-11 易语言例程 557 ℃ 1 评论
.版本 2
.支持库 spec

.程序集 窗口程序集1
.程序集变量 要取的进程名称, 文本型

.子程序 __启动窗口_创建完毕

要取的进程名称 = “360se.exe”
' 源码是易语言论坛一位版主的,我个人加了下自定义进程,外面有卖这个收费,但是我是因为自己要做加速器,才弄个这个东西,既然大家需要,那我就分享给大家吧

.子程序 yHan_GetLinks, , 公开, 取连接,支持win7
.局部变量 arg, 文本型, , "13"
.局部变量 pbuf, 整数型
.局部变量 i, 整数型
.局部变量 状态, 文本型
.局部变量 本地, 文本型
.局部变量 远程, 文本型
.局部变量 pid, 整数型
.局部变量 dwState, 整数型
.局部变量 win7, 逻辑型
.局部变量 hHeap, 整数型
.局部变量 num, 整数型

arg = { “已关闭”, “正在监听”, “同步发送”, “同步接收”, “已建立”, “FIN_WAIT1”, “FIN_WAIT2”, “关闭等待”, “正在关闭”, “最后确认”, “延时等待”, “删除”, “未知” }
hHeap = GetProcessHeap ()
.如果 (GetProcAddress (LoadLibrary (“iphlpapi.dll”), “AllocateAndGetTcpExTableFromStack”) = 0)
    InternalGetTcpTable2 (pbuf, hHeap, 1)
    win7 = 真
.否则
    AllocateAndGetTcpExTableFromStack (pbuf, 真, hHeap, 2, 2)
.如果结束

num = GetDate (pbuf, 0)
pbuf = pbuf + 4
.计次循环首 (num, i)
    ' 调试输出 (1 + i)
    dwState = GetDate (pbuf, 0)
    状态 = arg [选择 (dwState > 12 或 dwState < 1, 13, dwState)]
    本地 = 指针到文本 (inet_ntoa (GetDate (pbuf, 4))) + “:” + 到文本 (ntohs (GetDate (pbuf, 8)))
    远程 = 指针到文本 (inet_ntoa (GetDate (pbuf, 12))) + “:” + 到文本 (ntohs (GetDate (pbuf, 16)))
    pid = GetDate (pbuf, 20)
    .如果真 (pid = 进程_名取ID (要取的进程名称))
        调试输出 (“TCP”, 远程)
        ' 调试输出 (添加路由 (远程, “255.255.255.0”, “45.79.83.149”, , , ))

    .如果真结束

    pbuf = pbuf + 选择 (win7, 28, 24)
.计次循环尾 ()
HeapFree (hHeap, 0, pbuf)
' hHeap = GetProcessHeap ()
.' 如果 (win7)
    ' InternalGetUdpTableWithOwnerPid (pbuf, hHeap, 1)
.否则
    ' AllocateAndGetUdpExTableFromStack (pbuf, 真, hHeap, 2, 2)
.如果结束

.' 计次循环首 (GetDate (pbuf, 0), i)
    ' 本地 = 指针到文本 (inet_ntoa (GetDate (pbuf, 4))) + “:” + 到文本 (ntohs (GetDate (pbuf, 8)))
    ' pid = GetDate (pbuf, 12)
    ' 调试输出 (“UDP”, 本地, pid)
    ' pbuf = pbuf + 12
.' 计次循环尾 ()
' HeapFree (hHeap, 0, pbuf)

.子程序 GetDate, 整数型
.参数 addr, 整数型
.参数 offset, 整数型

返回 (取字节集数据 (指针到字节集 (addr + offset, 4), #整数型, ))

.子程序 _按钮1_被单击

yHan_GetLinks ()

@Nodesire

文件下载

Tags:

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

已有1位网友发表了看法:

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
邮箱轰炸器通用型验证码平台比心APP登录图文识别移动咪咕数美数组排序精易论坛辣妈帮屏幕取色自动审核进群自动更新进程信息API例程CharlesLua支持库易语言直尺工具源码Access数据库群控模拟器
最新评论