为编程爱好者分享易语言教程源码的资源网
免费易语言注册机教程 程序员交流社区 挂机,挂机器人服务器95一年 广告位招租 三叶资源网交流群④ 【采购季】上云仅¥223/3年
免费易语言注册机教程 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年
程序员交流社区 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年

网站首页 易语言相关 网络相关源码 正文

天眼查POST例程

三叶资源网 2019-09-21 网络相关源码 536 ℃ 0 评论

资源介绍:

天眼查POST例程

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口, , , ' 本源码来自三叶资源网(www.sanye.cx)

.子程序 __启动窗口_创建完毕
.局部变量 a1, 字节型, , "0"
.局部变量 i, 整数型
.局部变量 sogo, 文本型, , "0"
.局部变量 fxckStr, 文本型
.局部变量 a, 整数型
.局部变量 sgarr, 文本型

a1 = { 0, 16, 31, 25, 34, 34, 11, 0, 21, 23, 0, 18, 19, 18, 21, 2, 21, 2, 28, 36, 31, 28, 34, 11, 5, 18, 31, 16, 18, 21, 5, 31 }
' sogo = { “j”, “p”, “7”, “o”, “3”, “w”, “0”, “-”, “2”, “e”, “9”, “z”, “f”, “m”, “b”, “k”, “u”, “8”, “g”, “s”, “a”, “1”, “d”, “y”, “r”, “i”, “h”, “q”, “l”, “n”, “v”, “6”, “5”, “c”, “x”, “4”, “t” }
sogo = { “1”, “t”, “8”, “z”, “o”, “f”, “l”, “5”, “2”, “y”, “q”, “9”, “p”, “g”, “r”, “x”, “e”, “s”, “d”, “4”, “n”, “b”, “u”, “a”, “m”, “c”, “h”, “j”, “3”, “v”, “i”, “0”, “-”, “w”, “7”, “k”, “6” }

' ]' a893e026a35440aab6c040d88aefa2c8
' 调试输出 (取数组成员数 (a1), 取数组成员数 (sogo))
.计次循环首 (取数组成员数 (a1), i)
    ' 调试输出 (i + 1)
    fxckStr = fxckStr + sogo [a1 [i] + 1]
    ' 调试输出 (sogo [a1 [i]])
    ' a = a + 1
.计次循环尾 ()
调试输出 (fxckStr)

.子程序 _按钮1_被单击
.局部变量 a, 文本型
.局部变量 b, 文本型
.局部变量 a1, 文本型
.局部变量 b1, 文本型
.局部变量 a2, 文本型
.局部变量 token, 文本型
.局部变量 utm1, 文本型
.局部变量 utm2, 文本型
.局部变量 cookie, 文本型
.局部变量 cookiex, 文本型

网页访问 (“http://www.tianyancha.com/search/12345673?checkFrom=searchBox”, , , , cookie, , , , , , )
调试输出 (cookie)
a = “http://www.tianyancha.com/tongji/1234567.json?random=” + 时间_取现行时间戳 ()
b = 到文本 (网页访问 (a, , , cookie, , #常量1, , , , , ))
a1 = 文本_取出中间文本 (b, #常量2, #引号, , )
' 调试输出 (a1)
b1 = 字文到字 (a1)
token = 文本_取出中间文本 (b1, “token=”, “;”, , )
utm1 = 文本_取出中间文本 (b1, “wtf=function(){return'”, “'”, , )
utm2 = 子程序1 (utm1)
' 二级 = 字节集_查看 (到字节集 (一级))
调试输出 (utm2)
a = “http://www.tianyancha.com/search/1234567.json?&pn=1”
b = 编码_utf8到gb2312 (到文本 (网页访问对象 (a, , , cookie + “; token=” + token + “; _utm=” + utm2, , #常量3, , , , , , , , , )))
' Cookie: TYCID=bc001cc6b66f45139d5ee8d4b82e5b47; tnet=1.193.127.123; token=3238c07eb3c24d35a93efa3f356f2494; _utm=a893e026a35440aab6c040d88aefa2c8
' Connection: keep-alive
' 本源码来自三叶资源网(www.sanye.cx)
调试输出 (b)

.子程序 子程序1, 文本型
.参数 文本, 文本型
.局部变量 a1, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 sogo, 文本型, , "0"
.局部变量 fxckStr, 文本型
.局部变量 a, 整数型
.局部变量 sgarr, 文本型

a1 = 分割文本 (文本, “,”, )
' sogo = { “j”, “p”, “7”, “o”, “3”, “w”, “0”, “-”, “2”, “e”, “9”, “z”, “f”, “m”, “b”, “k”, “u”, “8”, “g”, “s”, “a”, “1”, “d”, “y”, “r”, “i”, “h”, “q”, “l”, “n”, “v”, “6”, “5”, “c”, “x”, “4”, “t” }
sogo = { “1”, “t”, “8”, “z”, “o”, “f”, “l”, “5”, “2”, “y”, “q”, “9”, “p”, “g”, “r”, “x”, “e”, “s”, “d”, “4”, “n”, “b”, “u”, “a”, “m”, “c”, “h”, “j”, “3”, “v”, “i”, “0”, “-”, “w”, “7”, “k”, “6” }

' ]' a893e026a35440aab6c040d88aefa2c8
' 调试输出 (取数组成员数 (a1), 取数组成员数 (sogo))
.计次循环首 (取数组成员数 (a1), i)
    ' 调试输出 (i + 1)
    fxckStr = fxckStr + sogo [到整数 (a1 [i]) + 1]
    ' 调试输出 (sogo [a1 [i]])
    ' a = a + 1
.计次循环尾 ()
返回 (fxckStr)
' 返回 (fxckStr)
' 调试输出 (fxckStr)
' 本源码来自三叶资源网
' (www.sanye.cx)

.子程序 字文到字, 文本型
.参数 文本, 文本型, , 数据必须以“,”分割,且无{}
.局部变量 i, 整数型
.局部变量 i1, 整数型, , "0"
.局部变量 a, 文本型, , "0"
.局部变量 a1, 文本型

a1 = 文本
a = 分割文本 (a1, “,”, )
.计次循环首 (取数组成员数 (a), i)
    加入成员 (i1, 到整数 (a [i]))
.计次循环尾 ()
返回 (到文本 (子字节集替换 (到字节集 (i1), { 0 }, {  }, , )))


.子程序 时间_取现行时间戳, 文本型, , 生成一个13位的现行时间戳。如:1325252169718
.局部变量 VBscript, 对象
.局部变量 结果, 文本型

VBscript.创建 (“ScriptControl”, )
VBscript.写属性 (“Language”, “JScript”)
VBscript.数值方法 (“ExecuteStatement”, “function time(){return new Date().getTime()}”)
结果 = VBscript.通用方法 (“Run”, “time”, ).取文本 ()
返回 (结果)

资源作者:

@小明无敌

资源下载:

文件下载

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
易语言教程爱奇艺登录YY精易编程助手内存皮肤进度复制文件夹百度APIflash动画快手did获取进销存系统压枪辅助十六进制同程APP国密算法鼠标离开悬停AES加密外挂案通用对话框类电脑QQ高级输入框
最新评论
友情链接