为编程爱好者分享易语言教程源码的资源网
免费易语言注册机教程 程序员交流社区 挂机,挂机器人服务器95一年 广告位招租 三叶资源网交流群④ 【采购季】上云仅¥223/3年
免费易语言注册机教程 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年
程序员交流社区 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年

网站首页 易语言相关 网络相关源码 正文

网易云手机登录开源

三叶资源网 2019-10-06 网络相关源码 356 ℃ 1 评论
.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击

子程序_登录 (编辑框1.内容, 编辑框2.内容)

.子程序 子程序_登录, 文本型
.参数 手机号, 文本型
.参数 密码, 文本型
.局部变量 checkToken, 文本型
.局部变量 cookie, 文本型
.局部变量 return, 文本型
.局部变量 a, 文本型
.局部变量 json, 类_json

checkToken = 子程序_获取checkToken ()
' 'qq498228619
.如果 (取文本长度 (checkToken) > 80)
    a = 网页_访问S (“https://music.163.com/weapi/login/cellphone?csrf_token=”, 1, V8JS调试 (#常量_登录, “test”, #引号 + 手机号 + #引号 + “,” + #引号 + 校验_取md5 (到字节集 (密码)) + #引号 + “,” + #引号 + checkToken + #引号), , cookie)
    a = 编码_URL解码 (a, 真)
    json.解析 (a)
    .判断开始 (json.取通用属性 (“account.id”) ≠ “”)
        调试输出 (“登录成功”, a, cookie)
        return = json.取通用属性 (“account.id”)
    .默认
        return = “登录失败 ”
    .判断结束

.否则
    return = “失败”
.如果结束
返回 (return)

.子程序 子程序_获取checkToken, 文本型
.局部变量 json, 类_json
.局部变量 return, 文本型
.局部变量 return_web, 文本型
.局部变量 tid, 文本型

tid = V8JS调试 (#常量_id, “Wb”, )
return = V8JS调试 (#常量_token, “test”, #引号 + tid + #引号, 1024)
返回 (return)

.子程序 __启动窗口_创建完毕

V8调试初始化 (取运行目录 () + “\v8.dll”)

.子程序 __启动窗口_将被销毁

V8调试销毁 ()

@青春失笑

文件下载

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

已有1位网友发表了看法:

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
注册微信群发人脸对比填表源码自动发布消息易语言滑动验证码桌面小精灵外挂案flash动画apihookE2EE支持库keep卷帘式菜单自动打怪HttpWatch破解版通用型读内存树型框查大鱼号昵称桌面透明背景时钟枚举IE插件
最新评论
友情链接