为编程爱好者分享易语言教程源码的资源网
辅助教程学习 程序员交流社区 挂机,挂机器人服务器95一年 广告位招租 三叶资源网交流群④ 【采购季】上云仅¥223/3年
广告位招租 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年
程序员交流社区 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年

网站首页 易语言相关 网络相关源码 正文

微视扫码QQ加速0.5天 接口

三叶资源网 2020-05-29 网络相关源码 167 ℃ 0 评论

部分代码:

.版本 2
.支持库 EThread
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 qrsig, 文本型

.子程序 _按钮1_被单击

获取二维码 ()

.子程序 获取二维码
.局部变量 信息, 文本型
.局部变量 json, 类_json

信息 = 编码_Utf8到Ansi (网页_访问 (“http://tool.clwl.online/wspeed/login.php?do=getqrpic&r=” + 时间_取随机时间戳 (), 0))
json.解析 (信息)
.如果真 (json.取通用属性 (“saveOK”) = “0”)
    qrsig = json.取通用属性 (“qrsig”)
    图片框_二维码.图片 = 编码_BASE64解码 (json.取通用属性 (“data”), 真)
    启动线程 (&监控二维码, , )
.如果真结束


.子程序 监控二维码
.局部变量 信息, 文本型
.局部变量 json, 类_json
.局部变量 sThrAppid, 文本型
.局部变量 iAuthType, 文本型
.局部变量 openid, 文本型
.局部变量 sSessionKey, 文本型
.局部变量 wsreq_logseq, 文本型
.局部变量 person_id, 文本型

.计次循环首 (100, )
    信息 = 编码_Utf8到Ansi (网页_访问 (“http://tool.clwl.online/wspeed/login.php?do=qrlogin&qrsig=” + qrsig + “&r=” + 时间_取随机时间戳 (), 0))
    json.解析 (信息)
    标签_状态.标题 = json.取通用属性 (“msg”)
    .如果真 (json.取通用属性 (“saveOK”) = “0”)
        sThrAppid = json.取通用属性 (“cookie.sThrAppid”)
        iAuthType = json.取通用属性 (“cookie.iAuthType”)
        openid = json.取通用属性 (“cookie.openid”)
        sSessionKey = json.取通用属性 (“cookie.sSessionKey”)
        wsreq_logseq = json.取通用属性 (“cookie['wsreq_logseq']”)
        person_id = json.取通用属性 (“cookie['person_id']”)
        调试输出 (sThrAppid, iAuthType, openid, sSessionKey, wsreq_logseq, person_id)
        信息 = 编码_Utf8到Ansi (网页_访问 (“http://tool.clwl.online/wspeed/login.php?do=speed”, 1, “sThrAppid=” + sThrAppid + “&iAuthType=” + iAuthType + “&openid=” + openid + “&sSessionKey=” + sSessionKey + “&wsreq_logseq=” + wsreq_logseq + “&person_id=” + person_id))
        json.解析 (信息)
        标签_状态.标题 = json.取通用属性 (“msg”)
        跳出循环 ()
    .如果真结束
    程序_延时 (1, 1)
.计次循环尾 ()

.子程序 __启动窗口_创建完毕

@迷糊老师

微视扫码QQ加速0.5天 接口.png

文件下载


Tags:微视扫码

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
微信刷步数组去重复格式化易语言多开中控源码微信公众号GDI源码线程池HTTP服务器E语言易语言CEF3模块SendMessageCMD输出亦表格时时彩二星缩水软件图像二值化COM程序调试POST调试工具FTP局域网快递查询工具
最新评论
友情链接