为编程爱好者分享易语言教程源码的资源网
辅助教程学习 程序员交流社区 挂机,挂机器人服务器95一年 易语言培训课大全 三叶资源网交流群④ 【采购季】上云仅¥223/3年
广告位招租 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年
程序员交流社区 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年

网站首页 易语言相关 网络相关源码 正文

易语言简易通讯源码

三叶资源网 2012-05-27 网络相关源码 456 ℃ 0 评论

资源介绍:

源码利用易语言服务器和客户组件实现简易通信效果。

我爱自学易语言

.版本 2

.程序集 网络封包
.程序集变量 m_Data, 字节集
.程序集变量 m_DataLen, 整数型
.程序集变量 m_errno, 整数型

.子程序 _初始化, , , 当基于本类的对象被创建后,此方法会被自动调用

m_errno = 0

.子程序 _销毁, , , 当基于本类的对象被销毁前,此方法会被自动调用



.子程序 clear, , 公开

m_Data = {  }
m_DataLen = 0
m_errno = 0

.子程序 init, , 公开

m_Data = {  }
m_DataLen = 0
m_errno = 0

.子程序 erase, , 公开
.参数 length, 整数型

m_DataLen = 取字节集长度 (m_Data) - length
m_Data = 取字节集右边 (m_Data, m_DataLen)

.子程序 peek, 逻辑型, 公开

m_errno = packet_check ()
.如果真 (m_errno = 0)
    返回 (真)
.如果真结束
返回 (假)

.子程序 errno, 整数型, 公开

返回 (m_errno)

.子程序 packet_check, 整数型, 公开, 0 可读取 1 等待写入 -1 错误
.局部变量 length, 整数型
.局部变量 magic, 整数型

' ----------------
' int magic
' int length
' byte data[length]
' ----------------
.如果真 (m_DataLen < 8)
    返回 (1)
.如果真结束
magic = 取字节集数据 (m_Data, #整数型, 1)
.如果真 (magic ≠ 305419896)  ' magic = 0x0ODEDEAD
    返回 (-1)
.如果真结束
length = 取字节集数据 (m_Data, #整数型, 5)  ' check length >= data length
.如果真 (length < 0)
    返回 (-1)
.如果真结束
.如果真 (length > 10240)
    返回 (-1)
.如果真结束
.如果真 (m_DataLen - 8 < length)
    返回 (1)
.如果真结束
返回 (0)

.子程序 append, , 公开
.参数 data, 字节集

m_Data = m_Data + data
m_DataLen = 取字节集长度 (m_Data)

.子程序 read, 字节集, 公开
.局部变量 data, 字节集
.局部变量 length, 整数型

data = {  }
.如果真 (peek () = 假)
    返回 (data)
.如果真结束
length = 取字节集数据 (m_Data, #整数型, 5)
data = 取字节集中间 (m_Data, 9, length)
erase (length + 8)
返回 (data)

.子程序 write, , 公开
.参数 data, 字节集
.局部变量 length, 整数型
.局部变量 magic, 整数型
.局部变量 packet_data, 字节集

magic = 305419896
length = 取字节集长度 (data)

packet_data = 到字节集 (magic) + 到字节集 (length) + data
append (packet_data)

.子程序 getData, 字节集, 公开

返回 (m_Data)

.子程序 getLength, 整数型, 公开

返回 (m_DataLen)


文件下载


来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
高级表格扩展类模块弹幕解析音频文件XUI腾讯小米路由器抖音动态加解密易语言做网站控制托盘图标QQPC8.6协议源码键值排序wordpress图片相似度对比界面引擎单课基础课程集合易语言教程组件移动例程文件拖拽易编辑框源码
最新评论
友情链接