为编程爱好者分享易语言教程源码的资源网
广告位招租 程序员交流社区 挂机,挂机器人服务器95一年 易语言培训课大全 三叶资源网交流群④ 【采购季】上云仅¥223/3年
广告位招租 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年
程序员交流社区 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年

网站首页 易语言相关 网络相关源码 正文

简单天涯对象法登录回贴采集全易语言源码

三叶资源网 2012-05-27 网络相关源码 550 ℃ 0 评论

资源介绍:

简单天涯登录回贴采集易语言源码例程程序结合易语言扩展界面支持库,调用API函数实现天涯登录回贴采集。易语言例程还使用到易语言互联网支持库,正则表达式支持库,超文本浏览框支持库,应用接口支持库。

资源作者:

@三叶资源网

.版本 2
.支持库 spec

.子程序 三无产品点击
.局部变量 句柄a, 整数型
.局部变量 对象集合, 对象
.局部变量 网页元素, 对象
.局部变量 网页元素1, 对象
.局部变量 计次1, 整数型
.局部变量 value, 文本型
.局部变量 type, 文本型
.局部变量 title, 文本型
.局部变量 fhf, 文本型, , "0"
.局部变量 add, 整数型, 静态

fhf = 分割文本 (回复.内容, #换行符, )
句柄a = 取网页句柄 (超文本浏览框1.取窗口句柄 ())
对象集合 = 取网页对象 (句柄a)
调试输出 (句柄a)

网页元素 = 对象集合.对象型方法 (“getElementById”, “textAreaContainer”)
.如果 (选择框2.选中 = 真)
    add = add + 1
    网页元素.写属性 (“value”, fhf [add], )
    调试输出 (fhf [add])
    调试输出 (add)
    .如果真 (add = 取数组下标 (fhf, ))
        add = 0
    .如果真结束

.否则
    网页元素.写属性 (“value”, 回复.内容, )
    调试输出 (回复.内容)
.如果结束

网页元素 = 对象集合.对象型方法 (“getElementsByTagName”, “input”)
.计次循环首 (网页元素.读数值属性 (“length”, ), 计次1)
    网页元素1 = 网页元素.对象型方法 (“item”, 计次1 - 1)  ' item的第一个参数是索引,从0开始。
    type = 网页元素1.读文本属性 (“type”, )
    value = 网页元素1.读文本属性 (“value”, )
    title = 网页元素1.读文本属性 (“title”, )
    .如果真 (type = “button” 或 value = “回复(Ctrl+Enter)” 或 title = “Ctrl+Enter快捷发表”)
        网页元素1.方法 (“click”, )
        到循环尾 ()
    .如果真结束

.计次循环尾 ()
.判断开始 (选择框2.选中 = 假)
    时钟1.时钟周期 = 0
.默认

.判断结束
' 如果真 (Type = “button” 或 Type = “submit” 或 Type = “reset” 或 Type = “image”)

资源下载:

文件下载


来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
粒子特效仿win8进度条分段加密淘宝宝贝列表分页源码超级编辑框代码框自绘软件加密QQ达人采集私信登录抓包工具鱼刺线程池程序调试屏幕录像信息框自绘滚动条cnzzt统计窗口信息内存调用炫彩界面
最新评论
友情链接