为编程爱好者分享易语言教程源码的资源网
三叶资源网易语言免费公开课
三叶资源网官方③群:33301895 三叶资源网解压密码 C全站文字广告,诚邀与您合作 三叶资源网培训教程视频 三叶资源网官方③群:33301895
三叶资源网官方③群:33301895 三叶资源网访问导航 B全站文字广告,诚邀与您合作 三叶资源网培训教程视频 三叶资源网官方③群:33301895

网站首页 易语言相关 网络相关源码 正文

快速读取网页易语言源码

三叶资源网 2012-05-27 网络相关源码 241 ℃ 0 评论

源码程序创建Microsoft.XMLHTTP对象快速读取网页源码。

@易语言学习网

.版本 2

.子程序 XMLhttp读文件, 字节集, 公开, 读网络文件,(成功返回网络文件字节集数据,失败返回空字节集)
.参数 网址, 文本型, , 欲访问的网络地址
.局部变量 对象, 对象
.局部变量 bp, 变体型

.如果真 (对象.创建 (“Microsoft.XMLHTTP”, ))
    .如果真 (到小写 (取文本左边 (网址, 7)) ≠ “http://”)
        网址 = “http://” + 网址
    .如果真结束
    对象.方法 (“open”, “GET”, 网址, 假)

    对象.方法 (“send”, )
    bp = 对象.读属性 (“responseBody”, )
    返回 (bp.取字节集 ())
.如果真结束
返回 ({  })

.子程序 XMLhttp读文本, 文本型, 公开, 读网络文本,(成功返回网络文本数据,失败返回空文本)
.参数 网址, 文本型, , 欲访问的网络地址
.局部变量 对象, 对象
.局部变量 bp, 变体型

.如果真 (对象.创建 (“Microsoft.XMLHTTP”, ))
    .如果真 (到小写 (取文本左边 (网址, 7)) ≠ “http://”)
        网址 = “http://” + 网址
    .如果真结束
    对象.方法 (“open”, “GET”, 网址, 假)
    对象.方法 (“send”, )
    bp = 对象.读属性 (“responseBody”, )
    返回 (到文本 (bp.取字节集 ()))
.如果真结束
返回 (“”)
文件下载


Tags:易语言源码

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方③群:33301895

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
交流QQ群:33301895
三叶资源网官方③群:33301895
加群全凭信仰,群里有的资源网站也会有。
群里只是能及时交流,群主会尽力解答一些会的问题。
设置付费入群,只是为了过滤一些小号无意义广告。
所以不必要为了1块钱加群又退出
群主在群内发的红包都够你抢回来还有的多,更何况还能交流学习。
网站分类
随机tag
三叶资源网深度学习POST教程代理注册邮箱轰炸器代码框自绘贴吧采集数组剖析UDPOCR识别粒子特效微信公众号超文本浏览框支持库博彩数据常量支持库采集源码图片生成器递归算法世宝教程OEM信息
最新评论