为编程爱好者分享易语言教程源码的资源网
广告位招租 程序员交流社区 挂机,挂机器人服务器95一年 易语言培训课大全 三叶资源网交流群④ 【采购季】上云仅¥223/3年
广告位招租 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年
程序员交流社区 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年

网站首页 易语言相关 网络相关源码 正文

快速读取网页易语言源码

三叶资源网 2012-05-27 网络相关源码 815 ℃ 4 评论

源码程序创建Microsoft.XMLHTTP对象快速读取网页源码。

@易语言学习网

.版本 2

.子程序 XMLhttp读文件, 字节集, 公开, 读网络文件,(成功返回网络文件字节集数据,失败返回空字节集)
.参数 网址, 文本型, , 欲访问的网络地址
.局部变量 对象, 对象
.局部变量 bp, 变体型

.如果真 (对象.创建 (“Microsoft.XMLHTTP”, ))
    .如果真 (到小写 (取文本左边 (网址, 7)) ≠ “http://”)
        网址 = “http://” + 网址
    .如果真结束
    对象.方法 (“open”, “GET”, 网址, 假)

    对象.方法 (“send”, )
    bp = 对象.读属性 (“responseBody”, )
    返回 (bp.取字节集 ())
.如果真结束
返回 ({  })

.子程序 XMLhttp读文本, 文本型, 公开, 读网络文本,(成功返回网络文本数据,失败返回空文本)
.参数 网址, 文本型, , 欲访问的网络地址
.局部变量 对象, 对象
.局部变量 bp, 变体型

.如果真 (对象.创建 (“Microsoft.XMLHTTP”, ))
    .如果真 (到小写 (取文本左边 (网址, 7)) ≠ “http://”)
        网址 = “http://” + 网址
    .如果真结束
    对象.方法 (“open”, “GET”, 网址, 假)
    对象.方法 (“send”, )
    bp = 对象.读属性 (“responseBody”, )
    返回 (到文本 (bp.取字节集 ()))
.如果真结束
返回 (“”)
文件下载


Tags:易语言源码

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

已有4位网友发表了看法:

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
今日头条音遇PCQQ音频转换大师腾达路由器宝宝树登录算法钓鱼分组框美化图片相似度对比scrcpy投屏QQ网页登录易语言通讯花椒直播工具保护壳创建时钟libMysql圆形进度条网页代理取文件列表高效数据结构
最新评论
友情链接