为编程爱好者分享易语言教程源码的资源网
易语言源码视频(易学院) A全站文字广告,诚邀与您合作 建站,挂机器人,挂监控服务器 易语言实地培训火热招生 三叶资源网官方③群:33301895
每日必买商品 20块一小时,一小时一结账 299买3年腾讯云服务器 乐易论坛 三叶资源网官方③群:33301895

网站首页 易语言相关 网络相关源码 正文

快速读取网页易语言源码

三叶资源网 2012-05-27 网络相关源码 352 ℃ 0 评论

源码程序创建Microsoft.XMLHTTP对象快速读取网页源码。

@易语言学习网

.版本 2

.子程序 XMLhttp读文件, 字节集, 公开, 读网络文件,(成功返回网络文件字节集数据,失败返回空字节集)
.参数 网址, 文本型, , 欲访问的网络地址
.局部变量 对象, 对象
.局部变量 bp, 变体型

.如果真 (对象.创建 (“Microsoft.XMLHTTP”, ))
    .如果真 (到小写 (取文本左边 (网址, 7)) ≠ “http://”)
        网址 = “http://” + 网址
    .如果真结束
    对象.方法 (“open”, “GET”, 网址, 假)

    对象.方法 (“send”, )
    bp = 对象.读属性 (“responseBody”, )
    返回 (bp.取字节集 ())
.如果真结束
返回 ({  })

.子程序 XMLhttp读文本, 文本型, 公开, 读网络文本,(成功返回网络文本数据,失败返回空文本)
.参数 网址, 文本型, , 欲访问的网络地址
.局部变量 对象, 对象
.局部变量 bp, 变体型

.如果真 (对象.创建 (“Microsoft.XMLHTTP”, ))
    .如果真 (到小写 (取文本左边 (网址, 7)) ≠ “http://”)
        网址 = “http://” + 网址
    .如果真结束
    对象.方法 (“open”, “GET”, 网址, 假)
    对象.方法 (“send”, )
    bp = 对象.读属性 (“responseBody”, )
    返回 (到文本 (bp.取字节集 ()))
.如果真结束
返回 (“”)
文件下载


Tags:易语言源码

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方③群:33301895

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网官方③群:三叶资源网官方③群

网站分类
随机tag
WORD文件加图片防撤回Asm田英章E2EE支持库FX3U通信火山安卓动画源码软件httpwacthsocks4抖音LOLAU商城拖放对象模块POST上传小号桃源挖矿运算模块支付宝贴吧采集
最新评论