为编程爱好者分享易语言教程源码的资源网
每日必买商品 易语言实地培训火热招生 建站,挂机,机器人服务器 A全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895
C全站文字广告,诚邀与您合作 乐易论坛 热门服务器秒杀 D全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895

网站首页 易语言相关 网络相关源码 正文

快速读取网页易语言源码

三叶资源网 2012-05-27 网络相关源码 420 ℃ 3 评论

源码程序创建Microsoft.XMLHTTP对象快速读取网页源码。

@易语言学习网

.版本 2

.子程序 XMLhttp读文件, 字节集, 公开, 读网络文件,(成功返回网络文件字节集数据,失败返回空字节集)
.参数 网址, 文本型, , 欲访问的网络地址
.局部变量 对象, 对象
.局部变量 bp, 变体型

.如果真 (对象.创建 (“Microsoft.XMLHTTP”, ))
    .如果真 (到小写 (取文本左边 (网址, 7)) ≠ “http://”)
        网址 = “http://” + 网址
    .如果真结束
    对象.方法 (“open”, “GET”, 网址, 假)

    对象.方法 (“send”, )
    bp = 对象.读属性 (“responseBody”, )
    返回 (bp.取字节集 ())
.如果真结束
返回 ({  })

.子程序 XMLhttp读文本, 文本型, 公开, 读网络文本,(成功返回网络文本数据,失败返回空文本)
.参数 网址, 文本型, , 欲访问的网络地址
.局部变量 对象, 对象
.局部变量 bp, 变体型

.如果真 (对象.创建 (“Microsoft.XMLHTTP”, ))
    .如果真 (到小写 (取文本左边 (网址, 7)) ≠ “http://”)
        网址 = “http://” + 网址
    .如果真结束
    对象.方法 (“open”, “GET”, 网址, 假)
    对象.方法 (“send”, )
    bp = 对象.读属性 (“responseBody”, )
    返回 (到文本 (bp.取字节集 ()))
.如果真结束
返回 (“”)
文件下载


Tags:易语言源码

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方⑤群:7366443

已有3位网友发表了看法:

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网官方⑤群:三叶资源网官方⑤群

网站分类
随机tag
奇易模块拖拽消息限制未授权U盘字节数聊天室例程易语言源码网田英章趣头条日期时间型动态壁纸SQLite3仿spy文件枚举KMP算法flash动画刺激战场辅助文本处理Windows身份验证无限视距调试
最新评论