为编程爱好者分享易语言教程源码的资源网
易语言源码视频(易学院) A全站文字广告,诚邀与您合作 建站,挂机器人,挂监控服务器 易语言实地培训火热招生 三叶资源网官方③群:33301895
每日必买商品 20块一小时,一小时一结账 299买3年腾讯云服务器 乐易论坛 三叶资源网官方③群:33301895

网站首页 易语言相关 网络相关源码 正文

读WAP网页易语言源码

三叶资源网 2012-05-27 网络相关源码 321 ℃ 0 评论

源码通过创建XMLHTTP对象,实现了网页访问功能,并且源码还实现了编码转化。

.版本 2

.子程序 读wap, 字节集, 公开, 读网络文件,(成功返回网络文件字节集数据,失败返回空字节集)
.参数 完整网址, 文本型, , 欲访问的完整的网络地址
.参数 访问方式, 文本型, 可空, "GET" or "POST",为空默认"GET"
.参数 提交数据, 文本型, 可空, 只限POST
.局部变量 对象, 对象
.局部变量 bp, 变体型

.如果真 (对象.创建 (“Microsoft.XMLHTTP”, ))
    .如果真 (取反 (取文本左边 (到大写 (完整网址), 7) = “HTTP://”))
        完整网址 = “HTTP://” + 完整网址
    .如果真结束
    .如果真 (访问方式 = “”)
        访问方式 = “GET”
    .如果真结束
    对象.方法 (“open”, 访问方式, 完整网址, 假)
    对象.方法 (“SetRequestHeader”, “Accept”, “application/vnd.wap.xhtml+xml,application/xml,text/vnd.wap.wml,text/html,application/xhtml+xml,image/png;q=0.5,image/jpeg;q=0.5,image/gif;q=0.5,image/*;q=0.6,*/*;q=0.6”)
    对象.方法 (“SetRequestHeader”, “User-Agent”, “SonyEricssonK800”)
    对象.方法 (“SetRequestHeader”, “Q-UA”, “KQB21_GA/210013&KMTT_3/200013&JV2&152020&SonyEricssonK800&0&4021&V3”)
    对象.方法 (“send”, 提交数据)
    bp = 对象.读属性 (“responseBody”, )
    返回 (bp.取字节集 ())
.如果真结束
返回 ({  })
文件下载

Tags:

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方③群:33301895

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网官方③群:三叶资源网官方③群

网站分类
随机tag
网页代理远程文件管理拖放支持库复制窗口加密与解密第四版bitmap动态调用汇编项目揭秘标签单据编辑器枚举类函数网页解析类通用型FX3U通信Charles自动售卡LOL免更新PostgreSQL数据库Safengine集中营易语言原子锁
最新评论