为编程爱好者分享易语言教程源码的资源网
免费易语言注册机教程 程序员交流社区 挂机,挂机器人服务器95一年 广告位招租 三叶资源网交流群④ 【采购季】上云仅¥223/3年
免费易语言注册机教程 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年
程序员交流社区 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年

网站首页 易语言相关 网络相关源码 正文

读WAP网页易语言源码

三叶资源网 2012-05-27 网络相关源码 578 ℃ 0 评论

源码通过创建XMLHTTP对象,实现了网页访问功能,并且源码还实现了编码转化。

.版本 2

.子程序 读wap, 字节集, 公开, 读网络文件,(成功返回网络文件字节集数据,失败返回空字节集)
.参数 完整网址, 文本型, , 欲访问的完整的网络地址
.参数 访问方式, 文本型, 可空, "GET" or "POST",为空默认"GET"
.参数 提交数据, 文本型, 可空, 只限POST
.局部变量 对象, 对象
.局部变量 bp, 变体型

.如果真 (对象.创建 (“Microsoft.XMLHTTP”, ))
    .如果真 (取反 (取文本左边 (到大写 (完整网址), 7) = “HTTP://”))
        完整网址 = “HTTP://” + 完整网址
    .如果真结束
    .如果真 (访问方式 = “”)
        访问方式 = “GET”
    .如果真结束
    对象.方法 (“open”, 访问方式, 完整网址, 假)
    对象.方法 (“SetRequestHeader”, “Accept”, “application/vnd.wap.xhtml+xml,application/xml,text/vnd.wap.wml,text/html,application/xhtml+xml,image/png;q=0.5,image/jpeg;q=0.5,image/gif;q=0.5,image/*;q=0.6,*/*;q=0.6”)
    对象.方法 (“SetRequestHeader”, “User-Agent”, “SonyEricssonK800”)
    对象.方法 (“SetRequestHeader”, “Q-UA”, “KQB21_GA/210013&KMTT_3/200013&JV2&152020&SonyEricssonK800&0&4021&V3”)
    对象.方法 (“send”, 提交数据)
    bp = 对象.读属性 (“responseBody”, )
    返回 (bp.取字节集 ())
.如果真结束
返回 ({  })
文件下载

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
文件夹加密E2EE无水印解析树形框项目揭秘手势验证码斗鱼弹幕助手手动记牌xmlhttpWKE易语言滑动验证码JS视频教程API创建窗口略缩图系统工具源码隐藏进程实时监控腾讯url.cn短网址微信群发器解析邮箱登陆
最新评论
友情链接