为编程爱好者分享易语言教程源码的资源网
易语言培训教程大全 程序员交流社区 挂机,挂机器人服务器95一年 广告位招租 三叶资源网交流群④ 【采购季】上云仅¥223/3年
广告位招租 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年
程序员交流社区 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年

网站首页 易语言相关 网络相关源码 正文

易语言显ip地理位置源码

三叶资源网 2013-07-08 网络相关源码 718 ℃ 1 评论

结合易语言彗星HTTP应用模块,读取网页源码取本机ip和地理位置。

.版本 2

.程序集 窗口程序集1

.子程序 _按钮2_被单击
.局部变量 address, 文本型
.局部变量 ip, 文本型

ip = 彗星HTTP读文本 (“http://ip.3322.net”)  ' 这里访问这个地址就会得到一个ip,之所以用这个网站是因为访问他只会得到一个ip地址,其它任何数据都没有,简单。
编辑框1.内容 = ip  ' 把ip地址显示出来
address = 彗星HTTP读文本 (“http://www.ip138.com/ips138.asp?ip=” + ip)  ' 这里用到ip138这个网站,把发送ip地址到这个网站会查到地理位置
编辑框3.内容 = 彗星URL解码 (到文本 (address))  ' 把返回的一大串数据显示出来
编辑框2.内容 = 取文本中间内容 (彗星URL解码 (到文本 (address)), “本站主数据:”, “</li><li>”, )  ' 把一大串数据中的地理位置给提取出来
' 下面是借用别人的一个子程序,取文本中间内容,这个比系统自带的更好用,好东西就要拿来用嘛

.子程序 取文本中间内容, 文本型
.参数 需取文本, 文本型
.参数 左边内容, 文本型
.参数 右边内容, 文本型
.参数 成功与否, 逻辑型, 参考 可空
.局部变量 长度, 整数型
.局部变量 左边位置, 整数型
.局部变量 左边长度, 整数型
.局部变量 右边位置, 整数型
.局部变量 右边长度, 整数型

长度 = 取文本长度 (需取文本)
左边位置 = 寻找文本 (需取文本, 左边内容, 0, 假)
左边长度 = 取文本长度 (左边内容)
' 三叶资源网(www.sanye.cx)
.如果真 (左边位置 = -1)
    成功与否 = 假
    返回 (“未找到左边内容”)
.如果真结束
右边位置 = 寻找文本 (需取文本, 右边内容, 0, 假)
右边长度 = 取文本长度 (右边内容)
.如果真 (右边位置 = -1)
    ' 三叶资源网(www.sanye.cx)
    成功与否 = 假
    返回 (“未找到右边内容”)
.如果真结束
成功与否 = 真
返回 (取文本中间 (需取文本, 左边位置 + 左边长度, 长度 - (左边位置 + 左边长度) - (长度 - 右边位置)))


文件下载

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

已有1位网友发表了看法:

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
快手自动发布图文golangsock5tcp协议模拟红绿灯QQ主显阿里系最新地址库quickjs加QQ好友取QQKEY快手获取QQ资料卡火山PC开发平台硬盘遍历虎牙登录源码YY圆形图像旋转HTMLayout标签闪字POST调试工具
最新评论
友情链接