为编程爱好者分享易语言教程源码的资源网
三叶资源网官方③群:33301895 网络创业点子 C全站文字广告,诚邀与您合作 三叶资源网培训教程视频 三叶资源网官方③群:33301895
三叶资源网官方③群:33301895 网络创业点子 B全站文字广告,诚邀与您合作 三叶资源网培训教程视频 三叶资源网官方③群:33301895

网站首页 易语言相关 网络相关源码 正文

易语言TCP读HTTP文件源码

三叶资源网 2013-03-10 网络相关源码 197 ℃ 0 评论

源码调用了易语言客户组件,演示了TCP方式访问网络的过程。

@客户端

.版本 2

.程序集 窗口程序集1
.程序集变量 计时

.子程序 _按钮1_被单击

.如果真 (客户1.连接 (“www.pctowap.com”, 80))
    .如果真 (客户1.发送数据 (#常量1))
        计时 = 取启动时间 ()
        返回 ()
    .如果真结束

.如果真结束
信息框 (“网络连接失败”, 0, “”)

.子程序 _客户1_数据到达
.局部变量 数据, 文本型

数据 = 到文本 (客户1.取回数据 ())
编辑框1.加入文本 (数据)
.如果真 (寻找文本 (数据, “0” + #换行符 + #换行符, , 假) ≠ -1)
    客户1.断开连接 ()
    标题 = “ok  耗时-” + 到文本 (取启动时间 () - 计时) + “毫秒”
.如果真结束
文件下载


Tags:

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方③群:33301895

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网官方③群:三叶资源网官方③群

网站分类
随机tag
超级列表框进程隐藏表白程序高并发http模型乐玩模拟器iiilab视频解析二维码信息框进制转换动态加密HttpServer1.1POST教程远程文件管理QQ注册二值化虎牙登录源码微信图片数据解密文本处理群控模拟器HttpWatch
最新评论