为编程爱好者分享易语言教程源码的资源网
每日必买商品 易语言实地培训火热招生 建站,挂机,机器人服务器 A全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895
C全站文字广告,诚邀与您合作 乐易论坛 热门服务器秒杀 D全站文字广告,诚邀与您合作 三叶资源网官方③群:33301895

网站首页 易语言相关 网络相关源码 正文

易语言TCP读HTTP文件源码

三叶资源网 2013-03-10 网络相关源码 268 ℃ 1 评论

源码调用了易语言客户组件,演示了TCP方式访问网络的过程。

@客户端

.版本 2

.程序集 窗口程序集1
.程序集变量 计时

.子程序 _按钮1_被单击

.如果真 (客户1.连接 (“www.pctowap.com”, 80))
    .如果真 (客户1.发送数据 (#常量1))
        计时 = 取启动时间 ()
        返回 ()
    .如果真结束

.如果真结束
信息框 (“网络连接失败”, 0, “”)

.子程序 _客户1_数据到达
.局部变量 数据, 文本型

数据 = 到文本 (客户1.取回数据 ())
编辑框1.加入文本 (数据)
.如果真 (寻找文本 (数据, “0” + #换行符 + #换行符, , 假) ≠ -1)
    客户1.断开连接 ()
    标题 = “ok  耗时-” + 到文本 (取启动时间 () - 计时) + “毫秒”
.如果真结束
文件下载


Tags:

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方⑤群:7366443

已有1位网友发表了看法:

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网官方⑤群:三叶资源网官方⑤群

网站分类
随机tag
udp广播组播读卡器开发易代码编辑框内存皮肤比特币获取群成员软件源码EXUI例程模块源码JSfiddler小号桃源挖矿模仿QQ登录变量数据交换淘宝登录按钮后台跳绳LOL无限视距iiilab视频解析刺激战场
最新评论