为编程爱好者分享易语言教程源码的资源网
免费易语言注册机教程 程序员交流社区 挂机,挂机器人服务器95一年 广告位招租 三叶资源网交流群④ 【采购季】上云仅¥223/3年
免费易语言注册机教程 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年
程序员交流社区 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年

网站首页 易语言相关 网络相关源码 正文

易语言TCP读HTTP文件源码

三叶资源网 2013-03-10 网络相关源码 661 ℃ 1 评论

源码调用了易语言客户组件,演示了TCP方式访问网络的过程。

@客户端

.版本 2

.程序集 窗口程序集1
.程序集变量 计时

.子程序 _按钮1_被单击

.如果真 (客户1.连接 (“www.pctowap.com”, 80))
    .如果真 (客户1.发送数据 (#常量1))
        计时 = 取启动时间 ()
        返回 ()
    .如果真结束

.如果真结束
信息框 (“网络连接失败”, 0, “”)

.子程序 _客户1_数据到达
.局部变量 数据, 文本型

数据 = 到文本 (客户1.取回数据 ())
编辑框1.加入文本 (数据)
.如果真 (寻找文本 (数据, “0” + #换行符 + #换行符, , 假) ≠ -1)
    客户1.断开连接 ()
    标题 = “ok  耗时-” + 到文本 (取启动时间 () - 计时) + “毫秒”
.如果真结束
文件下载


来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

已有1位网友发表了看法:

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
蓝奏网盘多线程防崩溃例程脚本源码WebUIsqllite窗口信息内存特征码硬盘遍历百度登陆BitBlt汇编版WebSocket加载皮肤bitlocker加密TGP登录协议网页POST会员管理系统软件异常重启屏幕保护撞球控制托盘图标田英章
最新评论
友情链接