为编程爱好者分享易语言教程源码的资源网
易语言源码视频(易学院) A全站文字广告,诚邀与您合作 建站,挂机器人,挂监控服务器 易语言实地培训火热招生 三叶资源网官方③群:33301895
每日必买商品 20块一小时,一小时一结账 299买3年腾讯云服务器 乐易论坛 三叶资源网官方③群:33301895

网站首页 易语言相关 网络相关源码 正文

易语言取多网卡MAC地址源码

三叶资源网 2013-03-02 网络相关源码 228 ℃ 1 评论

源码通过API函数取多网卡MAC地址。源码是WINDOWS API学习例程。

@黑客源码

.版本 2

.子程序 网络_取本机MAC, 文本型, 公开, 获取本机MAC地址,可以获取多网卡MAC,失败返回空。
.参数 网卡序号, , 可空, 可以被省略。当本机有多块网卡时,指定要对其操作的网卡序号(从1开始)。
.局部变量 IPAA, IP_ADAPTER_ADDRESSES
.局部变量 pAdapterAddresses
.局部变量 outBufLen
.局部变量 Flags
.局部变量 Family
.局部变量 lRet
.局部变量 dwIndex
.局部变量 i
.局部变量 outBuff, 文本型, , "0"
.局部变量 MAC地址, 文本型, , "0"
.局部变量 tmpMAC, 文本型

Flags = 16
Family = 0
outBufLen = 0
pAdapterAddresses = 从堆栈分配内存_ (取进程堆栈句柄_ (), 8, 32)
lRet = GetAdaptersAddresses (Family, Flags, 0, pAdapterAddresses, outBufLen)  ' 第一次调用,如果缓冲区不够,会在outBufLen里返回所需要的缓冲区大小
.如果真 (lRet = 111)  ' 如果返回溢出,则重分配足够的内存
    pAdapterAddresses = HeapReAlloc (取进程堆栈句柄_ (), 8, pAdapterAddresses, outBufLen)
.如果真结束
lRet = GetAdaptersAddresses (Family, Flags, 0, pAdapterAddresses, outBufLen)  ' 这次是正式取了
.如果真 (lRet = 0)
    ' 三叶资源网(www.sanye.cx)
    i = 0
    重定义数组 (outBuff, 假, 1)
    拷贝内存_IP_ADAPTER (IPAA, pAdapterAddresses, Len_IP_ADAPTER (IPAA))
    tmpMAC = 取十六进制文本 (IPAA.PhysicalAddress [1]) + “-” + 取十六进制文本 (IPAA.PhysicalAddress [2]) + “-” + 取十六进制文本 (IPAA.PhysicalAddress [3]) + “-” + 取十六进制文本 (IPAA.PhysicalAddress [4]) + “-” + 取十六进制文本 (IPAA.PhysicalAddress [5]) + “-” + 取十六进制文本 (IPAA.PhysicalAddress [6])
    加入成员 (MAC地址, tmpMAC)
    .判断循环首 (IPAA.pNext ≠ 0)
        i = i + 1
        重定义数组 (outBuff, 真, i)
        拷贝内存_IP_ADAPTER (IPAA, IPAA.pNext, Len_IP_ADAPTER (IPAA))
        tmpMAC = 取十六进制文本 (IPAA.PhysicalAddress [1]) + “-” + 取十六进制文本 (IPAA.PhysicalAddress [2]) + “-” + 取十六进制文本 (IPAA.PhysicalAddress [3]) + “-” + 取十六进制文本 (IPAA.PhysicalAddress [4]) + “-” + 取十六进制文本 (IPAA.PhysicalAddress [5]) + “-” + 取十六进制文本 (IPAA.PhysicalAddress [6])
        .如果真 (tmpMAC ≠ “0-0-0-0-0-0”)
            ' 三叶资源网(www.sanye.cx)
            加入成员 (MAC地址, tmpMAC)
        .如果真结束
        处理事件 ()
    .判断循环尾 ()
.如果真结束
释放堆栈内存_ (取进程堆栈句柄_ (), 0, pAdapterAddresses)
.如果真 (是否为空 (网卡序号))
    网卡序号 = 1
.如果真结束
返回 (MAC地址 [网卡序号])
文件下载


Tags:

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方③群:33301895

已有1位网友发表了看法:

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网官方③群:三叶资源网官方③群

网站分类
随机tag
烧饼帝多线程教程问道辅助内存脚本二维码登录模仿QQ登录LOL采集网页图片源码一条游走的龙易语言通讯socks5雷电模拟器进销存系统超文本浏览框支持库蜗牛迷宫游戏SysDateTimePick32CURL仿360纵向滚动条Shell外壳编程微信图片数据解密云的多文档窗口界面支持库百度语音
最新评论