为编程爱好者分享易语言教程源码的资源网
易语言培训教程大全 程序员交流社区 挂机,挂机器人服务器95一年 广告位招租 三叶资源网交流群④ 【采购季】上云仅¥223/3年
广告位招租 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年
程序员交流社区 每日疯抢商品 建站服务器 便宜好看的文具盒 三叶资源网交流群④ 【采购季】上云仅¥223/3年

网站首页 易语言相关 易语言例程 正文

易语言倒计时源码

三叶资源网 2015-04-11 易语言例程 2492 ℃ 5 评论

易语言倒计时源码,源码是易语言调用API函数的应用教程。

.版本 2

.子程序 _开始_被单击

' 本源码来自三叶资源网(www.sanye.cx)
子程序_清理内存 ()
.如果 (总时间.内容 = “”)
    总时间.内容 = “1”
.否则

.如果结束
.如果 (开始.标题 = “B”)

    起始X = 5
    起始y = 5
    数字宽度 = 到整数 (宽度编辑框.内容)
    数字高度 = 到整数 (高度编辑框.内容)
    数字厚度 = 到整数 (厚度编辑框.内容)
    线条间隙 = 到整数 (间隙编辑框.内容)
    time = 到整数 (分钟.内容) × 60 + 到整数 (秒钟.内容)
    总时间.内容 = 到文本 (time)
    isalarm = 真
    isonce = 真
    是否倒数 = 真
    API_InitializeCriticalSection (多线程许可证)
    载入 (窗口1, , 假)
    绘图线程 = 0
    时钟1 = 1
    .判断循环首 (取反 (是否已创建 (窗口1)))
    .判断循环尾 ()
    子程序_绘图 (time)
    API_SetTimer (_启动窗口.取窗口句柄 (), 时钟1, 1000, &子程序_主时钟事件)

    开始.标题 = “S”
.否则
    开始.标题 = “B”
    暂停.标题 = “P”
    API_KillTimer (_启动窗口.取窗口句柄 (), 时钟1)
    是否倒数 = 假
    .如果真 (子程序_取线程状态 (绘图线程) = 2)
        子程序_等待线程 (绘图线程, 1000)
    .如果真结束
    ' API_TerminateThread (绘图线程, 0)
    .如果真 (子程序_取线程状态 (绘图线程) = 1)
        API_CloseHandle (绘图线程)
    .如果真结束

    API_DeleteCriticalSection (多线程许可证)
    窗口1.销毁 ()
.如果结束

@易语言源码分享站


文件下载

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网④群:72857039

已有5位网友发表了看法:

  • 易语言教程站

    易语言教程站  评论于 [2019-07-09 10:20:43]  回复

    易语言怎么怎么获取编辑框内容当做倒计时时间

  • 易语言

    易语言  评论于 [2020-09-10 20:07:27]  回复

    易语言如何实现时钟倒计时

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网④群:三叶资源网③群

网站分类
随机tag
辅助教程易语言资源网快捷回复饿了么字符串加密QQ邮箱APK查询工具POST调试工具QQ空间鱼刺多线程模块二维码登录hp-socket关键词采集clientToken算法kgtemp转MP3驱动开发教程文件搜索GDIPlus外挂案线程池
最新评论
友情链接