为编程爱好者分享易语言教程源码的资源网
好用的代理IP,游戏必备 ____广告位招租____ 服务器99/年 ____广告位招租____ ____广告位招租____ 挂机,建站服务器
好用的代理IP,游戏必备 ____广告位招租____ 服务器低至38/年 ____广告位招租____ ____广告位招租____ 挂机,建站服务器

网站首页 > 易语言相关 > 易语言例程 正文

易语言取Unix时间戳源码

三叶资源网 2024-03-14 20:14:46 易语言例程 854 ℃ 2 评论
.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 t

调试输出 (“     秒时间戳”, Unix (#TIMESTAMP_S))
调试输出 (“   毫秒时间戳”, Unix (#TIMESTAMP_MS))
调试输出 (“100微秒时间戳”, Unix (14))
调试输出 (“10 微秒时间戳”, Unix (15))
调试输出 (“   微秒时间戳”, Unix (#TIMESTAMP_US))
t = 取启动时间 ()
.计次循环首 (100000, )
    Unix (#TIMESTAMP_MS)
.计次循环尾 ()
调试输出 (取启动时间 () - t)

.子程序 Unix, 长整数型, 公开, 取当前UTC时间戳,默认取毫秒时间戳
.参数 digtCount, 整数型, 可空, 位数(小于18位).或使用 #TIMESTAMP_* 的常量.  默认为 #TIMESTAMP_MS

.如果真 (是否为空 (digtCount))
    digtCount = #TIMESTAMP_MS
.如果真结束
返回 (WinToUnix (Win (), digtCount))

.子程序 Win, 长整数型, 公开, 获取当前系统UTC(协调世界时)时间自1601年1月1日0时0分0秒以来的100纳秒间隔数。
.局部变量 wints, 长整数型

GetSystemTimeAsFileTime (取变量数据地址 (wints))
返回 (wints)

.子程序 WinToUnix, 长整数型, 公开, windows时间戳转Unix时间戳
.参数 wints, 长整数型
.参数 digtCount, 整数型

wints = sub64 (wints, 1.16444736e+017)
返回 (Div64 (wints, 求次方 (10, 17 - digtCount)))

.子程序 sub64, 长整数型, 公开
.参数 minuend, 长整数型
.参数 subtrahend, 长整数型

置入代码 ({ 93, 139, 68, 36, 4, 43, 68, 36, 12, 139, 84, 36, 8, 27, 84, 36, 16, 194, 16, 0 })
返回 (0)

.子程序 Div64, 长整数型, 公开, 长整数除法
.参数 dividend, 长整数型, , 被除数
.参数 divisor, 长整数型, , 除数

置入代码 ({ 93, 255, 116, 36, 16, 255, 116, 36, 16, 255, 116, 36, 16, 255, 116, 36, 16, 232, 3, 0, 0, 0, 194, 16, 0, 87, 86, 83, 51, 255, 139, 68, 36, 20, 11, 192, 125, 20, 71, 139, 84, 36, 16, 247, 216, 247, 218, 131, 216, 0, 137, 68, 36, 20, 137, 84, 36, 16, 139, 68, 36, 28, 11, 192, 125, 20, 71, 139, 84, 36, 24, 247, 216, 247, 218, 131, 216, 0, 137, 68, 36, 28, 137, 84, 36, 24, 11, 192, 117, 24, 139, 76, 36, 24, 139, 68, 36, 20, 51, 210, 247, 241, 139, 216, 139, 68, 36, 16, 247, 241, 139, 211, 235, 65, 139, 216, 139, 76, 36, 24, 139, 84, 36, 20, 139, 68, 36, 16, 209, 235, 209, 217, 209, 234, 209, 216, 11, 219, 117, 244, 247, 241, 139, 240, 247, 100, 36, 28, 139, 200, 139, 68, 36, 24, 247, 230, 3, 209, 114, 14, 59, 84, 36, 20, 119, 8, 114, 7, 59, 68, 36, 16, 118, 1, 78, 51, 210, 139, 198, 79, 117, 7, 247, 218, 247, 216, 131, 218, 0, 91, 94, 95, 194, 16, 0 })
返回 (0)

@b0y


文件下载


来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网⑤群:21414575

猜你喜欢

已有2位网友发表了看法:

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网⑤群:三叶资源网⑤群

网站分类
随机tag
验证码平台控制继电器群发源码自动更新软件自动更新抓包工具JBecQQ机器人插件教程百度登录未闻花名皮肤模块udp广播组播行内元素识别算法golang多线程防崩溃例程辅助源码脚本递归光标取模块采集源码
最新评论