为编程爱好者分享易语言教程源码的资源网
三叶资源网易语言免费公开课
三叶资源网官方③群:33301895 三叶资源网解压密码 C全站文字广告,诚邀与您合作 三叶资源网培训教程视频 三叶资源网官方③群:33301895
三叶资源网官方③群:33301895 三叶资源网访问导航 B全站文字广告,诚邀与您合作 三叶资源网培训教程视频 三叶资源网官方③群:33301895

网站首页 易语言相关 易语言例程 正文

3D排列3分析程序源码

三叶资源网 2018-12-20 易语言例程 43 ℃ 0 评论

3D排列3分析程序

.版本 2
.支持库 EChartBar
.支持库 eGrid

.子程序 更新曲线图1
.参数 列号, 整数型
.局部变量 计次, 整数型
.局部变量 列表格行号, 整数型
.局部变量 临时刻度, 整数型

.判断开始 (列号 > 0 且 列号 < 4)
    临时刻度 = 曲1.X轴标注数量
    曲1.X轴标注数量 = 0
    曲1.X轴标注数量 = 临时刻度
.判断 (列号 = 19 或 列号 = 20 或 列号 = 22 或 列号 = 24)
    临时刻度 = 曲1.X轴标注数量
    曲1.X轴标注数量 = 0
    曲1.X轴标注数量 = 临时刻度
.默认

.判断结束

.判断开始 (列号 < 4 且 列号 > 0)
    曲1.Y轴最大值 = 9
    曲1.Y轴刻度数 = 3

    .计次循环首 (曲1.X轴标注数量, 计次)
        .如果 (按钮5.标题 = “降序显示”)
            列表格行号 = 高级表格2.取光标行号 () - 计次 + 1
        .否则
            列表格行号 = 高级表格2.取光标行号 () + 计次 - 1
        .如果结束
        .如果真 (列表格行号 < 1)
            跳出循环 ()
        .如果真结束
        ' 输出调试文本 (列表格行号)
        曲1.当前X轴标注索引 = 计次 - 1
        曲1.当前数据值 = 到数值 (高级表格2.取数据 (列表格行号, 列号))
    .计次循环尾 ()

.判断 (列号 = 4)  ' 和值
    曲1.Y轴最大值 = 27
    曲1.Y轴刻度数 = 3
    .计次循环首 (曲1.X轴标注数量, 计次)
        .如果 (按钮5.标题 = “降序显示”)
            列表格行号 = 高级表格2.取光标行号 () - 计次 + 1
        .否则
            列表格行号 = 高级表格2.取光标行号 () + 计次 - 1
        .如果结束

        .如果真 (列表格行号 < 1)
            跳出循环 ()
        .如果真结束

        ' 输出调试文本 (列表格行号)
        曲1.当前X轴标注索引 = 计次 - 1
        曲1.当前数据值 = 到数值 (高级表格2.取数据 (列表格行号, 列号))
    .计次循环尾 ()

.判断 (列号 = 22 或 列号 = 20)  ' 跨度 和 合值
    曲1.Y轴最大值 = 9
    曲1.Y轴刻度数 = 9
    .计次循环首 (曲1.X轴标注数量, 计次)
        .如果 (按钮5.标题 = “降序显示”)
            列表格行号 = 高级表格2.取光标行号 () - 计次 + 1
        .否则
            列表格行号 = 高级表格2.取光标行号 () + 计次 - 1
        .如果结束

        .如果真 (列表格行号 < 1)
            跳出循环 ()
        .如果真结束

        ' 输出调试文本 (列表格行号)
        曲1.当前X轴标注索引 = 计次 - 1
        曲1.当前数据值 = 到数值 (高级表格2.取数据 (列表格行号, 列号))
    .计次循环尾 ()
.判断 (列号 = 24 或 列号 = 19)  ' 散度 和 余3
    曲1.Y轴最大值 = 2
    曲1.Y轴刻度数 = 2
    .计次循环首 (曲1.X轴标注数量, 计次)
        .如果 (按钮5.标题 = “降序显示”)
            列表格行号 = 高级表格2.取光标行号 () - 计次 + 1
        .否则
            列表格行号 = 高级表格2.取光标行号 () + 计次 - 1
        .如果结束

        .如果真 (列表格行号 < 1)
            跳出循环 ()
        .如果真结束

        ' 输出调试文本 (列表格行号)
        曲1.当前X轴标注索引 = 计次 - 1
        曲1.当前数据值 = 到数值 (高级表格2.取数据 (列表格行号, 列号))
    .计次循环尾 ()
.默认

.判断结束

@易语言教程网

3D排列3分析程序    


文件下载

Tags:

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方③群:33301895

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
交流QQ群:33301895
三叶资源网官方③群:33301895
加群全凭信仰,群里有的资源网站也会有。
群里只是能及时交流,群主会尽力解答一些会的问题。
设置付费入群,只是为了过滤一些小号无意义广告。
所以不必要为了1块钱加群又退出
群主在群内发的红包都够你抢回来还有的多,更何况还能交流学习。
网站分类
随机tag
集福卡奇易模块火山移动易语言5.11微信图片数据解密易语言5.8Bass音频库网易滑块位置识别易编辑框源码音频处理粒子特效Aplayerapk查壳工具易语言破解版吃鸡辅助字符串加密支持库开源淘宝登录加密壳超级列表框
最新评论