为编程爱好者分享易语言教程源码的资源网
三叶资源网官方③群:33301895 网络创业点子 C全站文字广告,诚邀与您合作 三叶资源网培训教程视频 三叶资源网官方③群:33301895
三叶资源网官方③群:33301895 网络创业点子 B全站文字广告,诚邀与您合作 三叶资源网培训教程视频 三叶资源网官方③群:33301895

网站首页 易语言相关 易语言例程 正文

3D排列3分析程序源码

三叶资源网 2018-12-20 易语言例程 90 ℃ 0 评论

3D排列3分析程序

.版本 2
.支持库 EChartBar
.支持库 eGrid

.子程序 更新曲线图1
.参数 列号, 整数型
.局部变量 计次, 整数型
.局部变量 列表格行号, 整数型
.局部变量 临时刻度, 整数型

.判断开始 (列号 > 0 且 列号 < 4)
    临时刻度 = 曲1.X轴标注数量
    曲1.X轴标注数量 = 0
    曲1.X轴标注数量 = 临时刻度
.判断 (列号 = 19 或 列号 = 20 或 列号 = 22 或 列号 = 24)
    临时刻度 = 曲1.X轴标注数量
    曲1.X轴标注数量 = 0
    曲1.X轴标注数量 = 临时刻度
.默认

.判断结束

.判断开始 (列号 < 4 且 列号 > 0)
    曲1.Y轴最大值 = 9
    曲1.Y轴刻度数 = 3

    .计次循环首 (曲1.X轴标注数量, 计次)
        .如果 (按钮5.标题 = “降序显示”)
            列表格行号 = 高级表格2.取光标行号 () - 计次 + 1
        .否则
            列表格行号 = 高级表格2.取光标行号 () + 计次 - 1
        .如果结束
        .如果真 (列表格行号 < 1)
            跳出循环 ()
        .如果真结束
        ' 输出调试文本 (列表格行号)
        曲1.当前X轴标注索引 = 计次 - 1
        曲1.当前数据值 = 到数值 (高级表格2.取数据 (列表格行号, 列号))
    .计次循环尾 ()

.判断 (列号 = 4)  ' 和值
    曲1.Y轴最大值 = 27
    曲1.Y轴刻度数 = 3
    .计次循环首 (曲1.X轴标注数量, 计次)
        .如果 (按钮5.标题 = “降序显示”)
            列表格行号 = 高级表格2.取光标行号 () - 计次 + 1
        .否则
            列表格行号 = 高级表格2.取光标行号 () + 计次 - 1
        .如果结束

        .如果真 (列表格行号 < 1)
            跳出循环 ()
        .如果真结束

        ' 输出调试文本 (列表格行号)
        曲1.当前X轴标注索引 = 计次 - 1
        曲1.当前数据值 = 到数值 (高级表格2.取数据 (列表格行号, 列号))
    .计次循环尾 ()

.判断 (列号 = 22 或 列号 = 20)  ' 跨度 和 合值
    曲1.Y轴最大值 = 9
    曲1.Y轴刻度数 = 9
    .计次循环首 (曲1.X轴标注数量, 计次)
        .如果 (按钮5.标题 = “降序显示”)
            列表格行号 = 高级表格2.取光标行号 () - 计次 + 1
        .否则
            列表格行号 = 高级表格2.取光标行号 () + 计次 - 1
        .如果结束

        .如果真 (列表格行号 < 1)
            跳出循环 ()
        .如果真结束

        ' 输出调试文本 (列表格行号)
        曲1.当前X轴标注索引 = 计次 - 1
        曲1.当前数据值 = 到数值 (高级表格2.取数据 (列表格行号, 列号))
    .计次循环尾 ()
.判断 (列号 = 24 或 列号 = 19)  ' 散度 和 余3
    曲1.Y轴最大值 = 2
    曲1.Y轴刻度数 = 2
    .计次循环首 (曲1.X轴标注数量, 计次)
        .如果 (按钮5.标题 = “降序显示”)
            列表格行号 = 高级表格2.取光标行号 () - 计次 + 1
        .否则
            列表格行号 = 高级表格2.取光标行号 () + 计次 - 1
        .如果结束

        .如果真 (列表格行号 < 1)
            跳出循环 ()
        .如果真结束

        ' 输出调试文本 (列表格行号)
        曲1.当前X轴标注索引 = 计次 - 1
        曲1.当前数据值 = 到数值 (高级表格2.取数据 (列表格行号, 列号))
    .计次循环尾 ()
.默认

.判断结束

@易语言教程网

3D排列3分析程序    


文件下载

Tags:

来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网官方③群:33301895

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网官方③群:三叶资源网官方③群

网站分类
随机tag
火山安卓TCP通信TCP挂机心跳通用架构wordpress注册高并发http模型借呗多进程自动更新JavaScript进销存系统短信轰炸机PPT采集预览office2019激活封包组包拖放支持库对象增强操作模块拼多多下单WEB交互炫彩设计器工程易编辑框源码
最新评论