为编程爱好者分享易语言教程源码的资源网
好用的代理IP,游戏必备 ____广告位招租____ 服务器99/年 ____广告位招租____ ____广告位招租____ 挂机,建站服务器
好用的代理IP,游戏必备 ____广告位招租____ 服务器低至38/年 ____广告位招租____ ____广告位招租____ 挂机,建站服务器

网站首页 > 易语言相关 > 易语言例程 正文

易语言速度很快的文本操作汇编代码

三叶资源网 2020-10-27 10:01:59 易语言例程 1387 ℃ 1 评论
.版本 2
.支持库 spec

.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行
.局部变量 计时, 整数型
.局部变量 文本, 文本型
.局部变量 内容, 字节集

文本 = 取空白文本 (1024 × 1024 × 10)
内容 = 到字节集 (文本) + 到字节集 (“jr21066”)
计时 = 取启动时间 ()
.计次循环首 (100, )
    取文本长度 (文本)
.计次循环尾 ()
调试输出 (“系统取文本长度”, 取启动时间 () - 计时)
计时 = 取启动时间 ()
.计次循环首 (100, )
    取文本长度_SSE2_汇编 (文本)
.计次循环尾 ()
调试输出 (“汇编取文本长度”, 取启动时间 () - 计时)
计时 = 取启动时间 ()
.计次循环首 (100, )
    寻找字节集 (内容, 到字节集 (“jr21066”), )
.计次循环尾 ()
调试输出 (“系统寻找字节集”, 取启动时间 () - 计时)
计时 = 取启动时间 ()
.计次循环首 (100, )
    寻找字节集_SSE_汇编 (内容, 到字节集 (“jr21066”), )
.计次循环尾 ()
调试输出 (“汇编寻找字节集”, 取启动时间 () - 计时)
计时 = 取启动时间 ()
.计次循环首 (10, )
    字节集到十六进制文本_汇编 (内容)
.计次循环尾 ()
调试输出 (“字节集到十六进制文本_汇编”, 取启动时间 () - 计时)
计时 = 取启动时间 ()
.计次循环首 (10, )
    十六进制文本到字节集_汇编 (文本)
.计次循环尾 ()
调试输出 (“十六进制文本到字节集_汇编”, 取启动时间 () - 计时)
返回 (0)  ' 可以根据您的需要返回任意数值

@jr21066

文件下载


来源:三叶资源网,欢迎分享,公众号:iisanye,(三叶资源网⑤群:21414575

猜你喜欢

已有1位网友发表了看法:

欢迎 发表评论:

百度站内搜索
关注微信公众号
三叶资源网⑤群:三叶资源网⑤群

网站分类
随机tag
SmartQQgolangphpotoshopSendMessage取文件列表LOL免更新12306抢票闪送APP聊呗bilibili直播MiniBlink易语言通讯Hp-Socket1饿了么Shell外壳编程apk查壳工具验证码平台网易登录聊呗网页端模块
最新评论